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Introduction
Safety instructions
•
•
•

Only use the power supply supplied with your LanBox. If your power supply is defective, a
replacement can be ordered at LanBox Products.
Do not use the LanBox at temperatures above 40° Celsius. This could damage the circuitry.
Never suspend the LanBox by its cable connections. When suspending the LanBox, make use
of appropriate equipment and use a safety steel.

About this document
This document is intended as a manual for the LCedit+ software in combination with the LanBox. It is
specifically written for the LanBox-LCX, but can also be used for the LanBox-LC, LC+, LCE and LCM.
Although we have taken the utmost care to make this manual as complete as possible, due to the
extensive range of possibilities of the LanBox, some features may be overlooked. Do not hesitate to
contact us whenever you stumble upon anything not described (fully) by this manual. We are happy to
assist you and, when necessary, update this document.

About the LanBox
The LanBox-LCX is a powerful and multipurpose box. It has Ethernet, USB, MIDI in and out, DMX out,
DMX in, eight analog inputs and eight digital outputs. All these inputs and outputs can be programmed to
do anything: use an analogue fader to fade lights, control light cues through DMX, use Art-Net over
Ethernet to start eight iPods using the digital outputs as rs232 ports or use the DMX input to send MIDI
messages. It is all possible and most importantly: it will operate without a computer, reliable and for many
years. This manual will show you how to set up the LanBox to access all these functions, making use of
the LCedit+ software.
In- and Outputs
The LanBox has the following in- and outputs:
Front:
A:
B:
C:
D:

DMX-512 in and out
MIDI in and out
10bit Ethernet port
UDB Type B connector

Rear:
E:
F:

DC37s D-sub connector
Power supply connector

Image 1: The LanBox-LCX Front Panel

Image 2: LanBox-LCX rear panel
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About LCedit+
LCedit+ is the software suite specifically written to set up and control the LanBox. All the actual
processing is done by the LanBox, LCedit+ is nothing more then an interface to access the LanBox. This
is why LCedit+ will only work properly when connected to a LanBox.
LCedit+ is written in such a way that it is backwards compatible with every LanBox ever made, but all
features will only be accessible when using a LanBox-LCX. LCedit+ runs under Microsoft Windows or
Apple OS X (use versions up to 3.5 to use on PowerPC, use versions from 3.5.2 when using OS X 10.7
(Lion) and higher).
Although there will be some small cosmetic differences between different operating systems, LCedit+
should work exactly the same on either system. Project and Library files are readily exchangeable
between operating systems.

System requirements
PC
Processor:
Intel Pentium or higher
Operating system:
Microsoft Windows XP or higher
Screen Resolution:
Minimal of 1024x768 recommended
USB port or 10/100BT Ethernet connection.
Apple Macintosh
Processor:
Any Intel or PowerPC (use LCedit+ version 3.5 or lower when using PPC)
Operating System:
OS X 10.4 (Tiger) or higher. Use LCedit 3.5.2 or higher with OS X 10.7 (Lion)
Screen Resolution:
Minimal of 1024x768 recommended
USB port or 10/100BT Ethernet connection.

Setup and Install
Installing LCedit+
To install LCedit+, copy the software files (unpack when you are using a zipped folder!) to your computer.
For easy access, move the LCedit+ folder to your applications (OS X) or Program Files (Windows).
Simply start the application, no further installation is required.
Note: When opening LCedit+ in OS X, no main window will be visible when opening LCedit+ until you
open a new project, only the menu bar will be visible.
USB setup
OS X:
The LanBox will be automatically detected and installed as an USB modem. If asked to set up the
interface, select Cancel.
Windows:
In Windows you will have to install the CDS USB modem driver the first time you connect the LanBox.
This is supplied with the LCedit+ software and available for download on www.lanbox.com. After
connecting the LanBox, find it in your device list. Select hardware → properties → drivers and install the
CDS UDB Modem driver (be sure to tell Windows to look in the LCedit+ folder). Windows will
automatically assign a COM port to the LanBox.
Note: LCedit+ is only able to detect COM ports 1 through 8. Sometimes Windows assigns a higher COM
port number to the LanBox. If this happens, open the device settings, go to the advanced COM port
settings and select a COM port number in the range of 1 through 8.
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Network setup
Connect the LanBox either directly to your computer or to your local network. The LanBox default
network settings are:
IP address:
Subnet Mask:
Standard Gateway:
Password:

192.168.1.77
255.255.255.0
192.168.1.1
777

If you are not familiar with computer networks, the consequences of these setting are as follows: the
Subnet Mask determines which IP addresses the LanBox will be able to communicate with. In this case,
the 255s mean numbers identical to your IP address, the 0 means any number. So in this case the
LanBox will be able to communicate with all computers and devices with an IP address of 192.168.1.x.
If you connect the LanBox directly to your computer, adjust your network settings to match the LanBox's
settings (so, for example an IP address of 192.168.1.100 and a network mask of 255.255.255.0). If you
are connected to a local network, set the LanBox to match your local network settings (so if, for example,
your router has an IP address of 192.168.10.1, you're computer will probably have an IP address of
192.168.10.x and the LanBox should be set to a free address in the same IP range).

Configuring the interface
When opening a new project (File → New Project...), the
'Configure Interface' window will appear (Image 3). In this
window you can tell LCedit+ which LanBox you want to
connect to and how you want to connect to it. Use a serial
connection if you have connected the LanBox using USB,
choose the TCP/IP connection if your LanBox is connected
with a network cable.
Note: the AppleTalk and MIDI tabs are still present due to
legacy reasons, but cannot be used in Windows XP and
higher or Mac OS X.
When using the serial connection, select the port of the
LanBox (COM x in Windows, usbmodemxxxx in OS X).
When using an Ethernet connection, type the LanBox IP
Address in the text box. The default is 192.168.1.77. If you
don't want to re-type the password every time you reconnect Image 3: Serial Set Up
to the LanBox, you can check the 'Save Password' box. The
default password is 777.
If you have multiple LanBoxes connected to your system, it is
wise to give each connection a name. This can be done in
the 'Name' text box.
The Connection Settings will be stored with your project and
LCedit+ will automatically attempt to reconnect when you reopen a saved project.
Note: You can access the 'Configure Interface' window at
any time by opening the Interfaces window (Window →
Interfaces) and double-clicking the LanBox Interface of which
you want to access the settings.
Image 4: TCP/IP Set Up
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LanBox concepts
Before you start working with the LanBox, it is best to familiarize yourself with some of the inner workings
of the LanBox. Although, in a lot of ways, the LanBox is quite similar to 'conventional' lighting controllers,
some concepts are very different from what you may be used to.

Layers
An unique property of the LanBox is that it works with Layers. Every Layer can run a Cue List and have a
certain amount of active Channels. The Number and order of Layers is completely customizable up to a
maximum of 31 Layers (except for the LanBox LC which has 8 fixed Layers). The way Layers are
organized, how the Mixer settings are applied and which Channels are active in each Layer all contribute
to the eventual output of the LanBox.
A reasonable analogy of how the LanBox Layers work is the
way Layers work in most graphics software. If you look at
Image 5, you can see several possible scenarios. Every
Layer contains a square. Layer A has a blue square, Layer B
a red square an C a green square. In the first situation, every
Layer's square occupies different pixels, so the order of the
Layers does not effect what you can actually see. Now, if you
move the squares in such a way that they overlap (situation
2), the way the Layers are ordered does matter. Layer A
obscures a bit of Layer B which in turn hides a bit of Layer C
from view. If you change the order of the Layers in such a
way that Layer B is the bottom Layer (situation 3), the red
square is even more hidden, and, when we move the
squares a bit, the red square even completely disappears
(situation 4)!
Now, if you replace the pixels with Light Channels and think
of the pixel color as the Channel value, you can see how the Image 5: The principle of layers
ordering of Layers can seriously influence the end values of
the Light Channels. Luckily though, the LanBox has several ways to actually use this principle to your
advantage, like Mixing Modes (what would happen if you would make the blue square 50% transparent?)
and Channel Control (move the squares around, or change their shapes). More on this will be discussed
in the section Channels and Layers on page 14 of this manual.

Mixer Buffers and Channels
Although one DMX-512 universe can contain a maximum of 512 Light Channels, the LanBox has a
potential of a lot more Channels, up to 3072 Channels in fact. This means that you have a lot of spare
Channels to store and manipulate a whole lot of values which you don't want to output to your DMX line.
You can copy incoming DMX values, UDP streams and analogue signals to any channel you like, and
then use them the way you prefer. All these values are stored in the LanBox in so called Buffers.
Every active Layer has a Buffer, but so does the DMX In- and Output, the analogue Input and most
importantly, the Mixer. The Mixer contains the values of all the LanBox Channel. When all calculations
are done and all the Layers have been added up, these values are stored in the Mixer Buffer. After this,
the LanBox copies the values that have to be sent over DMX, UDP, Art-Net etc. into the right Buffer and
broadcasts these values. By default, the LanBox transmits its first 512 Channels over DMX, but this can
easily be changed (see section Patching and Channel properties on page 44).

Cues
Of course it is possible to change every Light Channel manually, but in the vast majority of cases, that is
the last thing you would want (and, with current day intelligent Fixtures completely impossible). That is
why most of the time you will be using Light Cues. A Cue automates the control of your lights using
loops, fades, scenes, etc. The LanBox has the possibility to store up to 999 Cue Lists, each containing up
to 99 steps. Once stored, each Cue List can be called in any Layer for play back.
One of the unique things about the LanBox is that you can not only store Channel values, Goto
commands and fades in your Cues, it is also possible to program a lot of other actions into your Cues.
Start another Cue List in another Layer, wait for a specific clock time or even trigger events using other
Channels or Inputs as trigger. All these possibilities will be explored in the section Cue Lists on page 21.

LanBox concepts
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Saving your work
The LanBox is a Stand Alone Light Controller. This means that all the information it needs to run a show
is stored in the LanBox. The LanBox has two types of memory, its 'nonvolatile' flash ROM and its 'volatile'
RAM memory. The RAM memory is very quick in storing and querying data, but requires power to work
(this is what the volatile means). That means that anything stored here will be lost when you power down
the LanBox. To save your work, it will have to be copied to the flash ROM. This memory works a lot
slower, but will never loose its data.
To save your work go to Tools → Save LanBox Data (Ctrl Shift + S / ⌘ ⇧ + S ) in LCedit+. This will not
only store all Cue Lists and settings, but will also store the current LanBox state (all Channel values,
currently running Cue Lists, etc.).
What isn't saved on the LanBox is your Stage Data. You will have to save this as a project on your
computer (File → Save or Save As... , Ctrl + S / ⌘ + S). This is, together with the connection presets, the
only thing that is saved on your computer! All other data is only saved on the LanBox. It is possible
though to save the LanBox Data on your computer. You can copy all LanBox Data with the Backup
function, discussed in the section Backup and Restore on page 61.

On Boot
If the LanBox is supplied with power it will automatically boot (start up). The contents of the ROM will be
copied to the RAM and the LanBox will continue doing exactly that what it was doing the moment you
saved the LanBox Data. This means that you can set the LanBox up in such a way that it will
automatically start a completely predictable sequence at start up.

LanBox concepts
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LCedit+ overview
When you open LCedit+, you will see an empty screen. To start working with the LanBox, you will have
to create a project. In the menu bar, select File → New Project... (Ctrl + N / ⌘ + N) and configure your
LanBox connection as described in the section Configuring the interface on page 6.

Image 6: The LCedit+ interface

Now, LCedit+ will open the standard view (Image 6). On the right side you have the most important bit of
LCedit+ interface, the Control Panel (A). The Control Panel is your main interface with the LanBox. It
shows you which Layers are currently active, which Cue Lists are running, the memory and connection
status of the LanBox and will give you the possibility to manipulate your Channels. More on this panel
later. On the left you can see the Stage window (B). Here you can place your light Fixtures in order to
make it possible for you to select them and give you feedback on every Fixture's status. At the bottom of
the screen is the Cue List Editor (C). This window will be used to make and edit Cue Lists. These
windows will be covered more thoroughly in the sections that cover the Stage and Cue Lists.

The Control Panel
As said, the Control Panel (Image 7) is the main interface with
the LanBox. It has the following elements:
Command Line
Used to type direct commands, discussed on page 34.
Fixture presets
Every Fixture can be given presets. These can be recalled
here. Discussed on page 15.
Fixture controls
This section will show all the controls of your selected Fixture.
Will be fully covered in section Controlling you Fixtures, page
14.
Command macros
Here you can record and run Command Macros. Discussed
on page 34.
Layer Control
Control and manipulate Layers, load Cue Lists, etc. Will be
covered in section Layer Control on page 16.

Image 7: The Control Panel
LCedit+ overview
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Setting up the Stage
In order to be able to select and control any Channels, you will have to add them to your stage first. The
stage can be adjusted in such a way that it resembles the actual setup of your Fixtures. If needed, it is
possible to have multiple stages with different elements of your set up. Add a Stage window by selecting
Window → New Stage Window (Ctrl Shift Alt +T / ⌥ ⇧ ⌘ + T) in the menu bar. Setting up the stage can
be a lot of work, but if you do it properly, it can spare you a lot of time later.

Adding Fixtures
To add a Fixture to the stage, select the Stage Window and
select Edit → New Fixture... (Ctrl + K / ⌘ + K) to open the
Fixture Setup window. Here you can select your the Fixture
you want to add to your stage. You can also set the Base
Channel. As long as the DMX patch isn't changed, this will
be identical to the DMX Base Address of the Fixture. If your
Fixture is not listed, you can make a new one. How to do this
is described in the section 9, Fixture Definitions. In the
Fixture Setup window you can give your Fixture a name and
a 'Short name'. The Short name is the name of the Fixture
that will be displayed on the stage. If no Short name is given,
the normal name will be displayed. It is smart to let your
Fixture name end with a number (normally 1 for the first
Fixture off a given type), as LCedit+ will automatically
increment this number when duplicating items.
When you want to place multiple identical Fixtures, you can
Image 8: The Fixture Setup window
duplicate a Fixture by Alt / ⌥ + dragging a Fixture, or by
selecting one or more and selecting Edit → Duplicate (Ctrl + D / ⌘ + D). Duplicated items will
automatically be numbered and given an sequential base channel. The items will be duplicated in the
same order in which you have selected them, so if, for example, you select Fixtures 1 through 4 in revere
order, the duplicates will be numbered 8, 7, 6, 5 (Image 9).
After you have placed a Fixture, it is always possible to edit
its properties by double clicking the Fixture or by selecting
Edit → Edit Item... (Ctrl + E / ⌘ + E).

View options

In the View Menu (Image 10), you can select different
options to adjust the look and behavior of your Fixture icon:
Small reduces the size of your icon to 16x16 pixels (normal
is 32x32 pixels).

Image 9: Items duplicated in reverse order

Icon Hidden hides the Fixture icon and only shows the label.
Label Hidden hides the Fixture label and only shows the icon.
Intensity Indicator adds an Intensity bar next to the Fixture icon.
Position Indicator adds a horizontal and vertical slider to the icon to indicate
movement (only works if the Fixture has a pan/tilt function).
Color Indicator replaces the Fixture icon with a colored square, indicating the
RGB value of that Fixture. Only gives a color if the Fixture has a RGB function,
Image 10: The View Menu
will show a black to white gradient indicating the Fixture intensity.
Show Numbering toggles if the Fixture ID number (between the {}) is visible. The ID numbers will be
used to quick select your Fixtures and groups with the Command Line Interface commands.
Position Locked, when on, disables the possibility to (accidentally) move the Fixture icon and disables
the possibility to open a Fixtures properties by double-clicking.

Setting up the Stage
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Changing your Fixture icon
In LCedit+ it is very easy to change the icons of your Fixtures on the stage. Simply select the Fixture(s)
you want to change the icon of, open the Fixture setup of the selection by double clicking the Fixture or
by selecting Edit → Edit Item... (Ctrl + E / ⌘ + E). Now, you can change either the small or large icon (or
both) by selecting the icon and paste (using Ctrl/⌘ + C/V) another graphic into the icon square. This can
be a self made graphic, but an image copied from you browser will work just as well. Note that the icons
are quite small, so keep the picture simple and clear.

Creating a background
In some situations, it might come in handy to add a
background to your stage, like the floor plan of a venue or
the trussing of your stage (Image 11). In order to do this, you
will first have to have a background image. As you can't resize the background image, be sure to make the image more
or less the same size as your stage window (in pixels).
When you have your background image, open it in any
preview or graphics software and copy its contents to the
clipboard. Then, if you Ctrl + click (both on Mac and
Windows) on the stage, you will see the Stage Background Image 11: A background picture in the stage
menu (Image 12). Here you can choose you paste you
clipboard content onto the stage. As you can see, you can
also copy, cut and clear the background here. If you want to
move the background, hold down Ctrl + Alt (Windows) or Ctrl
⌥ (Mac) to drag the background.
Note: it is only possible to copy the contents of a file to the
stage, not the actual file itself.

Grouping

Image 12: The Stage Background Menu

To have quicker access to groups of Fixtures, you can make
groups. This way you can select all Fixtures of the same
type, all odd numbered Fixtures, or any other group at once.
To make a group, select the Fixtures you want to group and
select Edit → Make Group... (Ctrl Alt + M / ⌘ ⌥ + M) to open
the Group Setup Window (Image 12). Here, you can give
your group a name, add and remove Fixtures, change the
order of the Fixtures and change the icons in the same way
you change a Fixture icon: select the icon and copy a
graphic from the clipboard into it. The merge options
determine how the Fixtures in your group will be represented
in the Fixture Controls.
Smart Merge will merge all Fixture functions, but will also
show the intensity channels for each Fixture separately.

Image 13: The Group Setup Window

Concatenate will not merge any Fixture function, but will
show all channels of every Fixture in the Fixture Controls.
Simple Merge will merge all Fixture functions and will not show the separate intensity channels.
Now, if you fill your stage up with all your Fixtures, use the right view options and customize your icons
and background, you can eventually end up with a Stage Window like in Image 14 on the next page.

Setting up the Stage
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Image 14: A filled and customized Stage window

An Example Show
The Fixtures
Image 14 shows an example show we have made for this manual to cover the basic lighting functions.
What we have done here is first add a background to the stage window. This background is simply made
with a drawing of a truss found on the internet (source: www.prolyte.com), pasted together and copied to
the Stage Window. After this, the Fixtures are added:
The moving head Fixtures were given intensity and position indicators. The Robe ColorWash 250 did not
have a clear icon in the library, so it was pasted in.
The Martin Atomic strobes were added and given a distinctive (stock) icon. I find an intensity indicator not
useful for a strobe light, so I left it out.
Then there are 18 4-channel RGB Fixtures in a 6x3 matrix, which are given color indicators, and 18
PAR64 Fixtures were also put in. These are just generic DMX channels from the library. In order to tell
them apart easily, the standard icons have been replaced with colored squares matching the filter color.
A smoke machine was also added (a generic DMX channel as well) and given a custom icon.
Note: when placing intelligent Fixtures, always make sure that you have the right DMX mode selected.
This is often easily identified by the number of DMX channels that are used by a Fixture. Check your
Fixture's manual to learn more about its DMX modes (also called personality).
Note: always use single Fixtures when using composite Fixtures like dimmer packs (multiple single DMX
channels) and LED panels (multiple RGB dimmer packs). The multi-dimmer packs in the library are
meant for use with unknown Fixtures with multiple channels. When using these for dimmer packs you
won't always be able to control the channels separately.
The grouping
After placing the Fixtures, the groups are made. On the example Stage we made some groups that would
come in handy normally but other combinations are possible as well of course. Note that a Fixture can be
part of several groups.
Setting up the Stage
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The Cast Window
In order to see an overview of your Fixtures and their DMX
channels, you can use the Cast Window. To open this, select
Window → Cast Window (Ctrl + 0 / ⌘ + 0). The Cast
Window (Image 15) shows a complete list of all the Fixtures
on your stage with their channels. As we didn't change any
DMX Patch settings, the Channels and DMX Channels are
the same. This list can prove itself useful when addressing
your light Fixtures or when making your Patch table later.

Viewing Patch Data
In order to get a quick overview of which Fixture Parameters
are patched to which Mixer or DMX Channel, open the
Fixture Setup window of the Fixture by double clicking the
Fixture (if it hasn't been locked in the View Options) or by
selecting the Fixture and selecting Edit → Edit Item... in the
menu. In the Patch tab of the Fixture Setup window you can
view all the parameters of the Fixture and which Channels
they use (Image 17). Here you can view the Channel Offset
for each parameter (first column, labeled 'O'), the control
parameter name (labeled 'panel'), the Mixer Channel of that
parameter, the DMX Channel (the same as the Mixer
Channel if you use a 1:1 DMX Patch) and the different Patch
functions (see the section Patching and Channel properties Image 15: The Cast Window
for more information).

Renumbering the Fixtures
LCedit+ automatically gives a quick select number to the
Fixtures you place on the Stage. To change these numbers
(for example, to let every Fixture type start at another
hundred, so 101 and further for moving heads, 201 and
further for PAR lights), select the Fixtures you want to
renumber in the order you want them numbered. In the
menu, select File → Extra → Renumber Selection to open
the Renumber Window (Image 17), give a new first number
for the selection and select OK. If the range of numbers is
already in use for other Fixtures, these will be renumbered
with the original numbers of your selection.

Image 16: The Fixture Patch information

Image 17: The Renumber window

Setting up the Stage
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Controlling you Fixtures
To have control over a Fixture or Channel, it will have to be placed
on the stage first (see previous section). When you select one or
multiple Fixtures on the Stage or in the Cast Window, one or more
groups or even a combination, the Control options for these
Fixtures will become available in the Fixture Controls section of the
Control Panel (Image 18). In this panel you will see the following
elements:
Master Intensity: the Gain Function for the selected Fixtures. This
is not a normal control and should only be used in special
circumstances. It is fully described in the Gain section on page 44.
Fixture Controls: here you have all the controls for the different
parameters of the selected Fixture(s). If you have multiple identical
Fixtures selected, these controls will apply to all of them (the
controls are 'merged'). When you have Fixtures of different types
selected, merging of the controls isn't possible.
Individual intensities: when you have multiple Fixtures selected,
each Fixture will have its own individual intensity wheel here.
For now, we skip the 'Master Intensity' and proceed to the Fixture
Parameter Controls right away. values of different parameters can
be adjusted by either pulling the corresponding wheel, pressing a
button, selecting the number box and using the up and down
arrows on your key board or by typing a value in the number box
directly. The TAB key can be used to jump between number boxes,
Shift+TAB jumps up. When typing in the number box, typing a 'h'
switches the value to a hexadecimal value, a '%' to a percentage
and ending with a '.' makes it a numeric value (0-255). Typing a '+'
or a '-' sign makes it a relative value ( a +10% will make 60% out of
50%).
If a parameter has buttons, pressing the button will set the
parameter's Channel value to the value assigned to the button. In
some cases it is possible to change a parameter within a button
preset range, for example with strobe speed or continuous color Image 18: The Fixture control panel
scrolling. If a parameters has a 16bit value, it will have two wheels
and number boxes, a course and a fine value (Image 19). The color
of the value text indicates I a Channel is active in the selected
Layer. If the text of the parameter value is gray, this means that this Image 19: a 16bit control
Channel is not currently activated in the selected Layer. If it is
activated, the text will be black.
Next to every parameter control there are two small buttons. The lower red one indicates if the control is
in Solo Mode, this will be covered in section Solo Mode on page 19. The top one indicates if a parameter
value is being sent to the Mixer. This will be covered in the next section.

Channels and Layers
It does matter greatly in which Layer you control your Fixtures. Every Layer will only process the
Channels that are activated in that Layer, and will only output the values of those Channels of which the
output is switched on. Normally, a Channel's output is automatically switched on as soon as it is activated
in that Layer (it is possible to switch this option off, see section Other Layer Options on page 20) and can
therefore influence the Channel's value in the Mixer. It is important to keep track of which Channels are
active in which Layer in order to keep full control over your show. As mentioned before, if a Channel is
activated in a Layer, its value will be displayed in black. You can deactivate all Channels in a Layer by
selecting Layer → Clear Layer (Ctrl Sfit + C / ⌘ ⇧ + C) or clicking the Clear Layer button in the Layer
Control Panel (see section Layer Control on page 16).
For each Fixture, you can activate any number of parameters. This means that you can control every
parameter in a different Layer. In most cases, this is even highly recommended. This way you can use
one Layer for a Fixture group's intensities, one for its movements, etc. The only parameters that will
always be linked are the 16bit Channel pairs. Activating one of these will automatically activate the other
Channel.
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Switching Output and Solo
To the left of each Parameter, there are two small buttons, the top one green, the bottom one red. These
buttons control separate Channel Settings. With the top green button the output for this Channel can be
toggled on or off. This automatically switches on (and the green button lights up) when a Channel is
activated in a Layer, but can be switched off (and on again) using this button.
The other (red) button is used to set the Channel into Solo. This is further explained in the section Solo
Mode on page 19.

Using and making Presets
A quick way to set parameters for your Fixtures is using the
Preset menus (Image 20). There are four Preset groups:
Shutter (ps), used for intensity and shutter Presets, Beam
(pb), used for beam parameters such as gobo and focus,
Color (pc) and Other (po) for any presets that do not fit the
other categories or are combinations of categories. Presets
can be a great asset aiding you with the uniformity of your
show as well as making the controlling of Fixtures much
faster, especially as there can be several parameters saved
in one Preset. Some of the Presets are saved in a Fixture
library file, so they will already be there (see section 9 Fixture
Image 20: The Preset Menus
Definitions for more information on this), but is is also
possible to add presets in you project.
To make a Preset, set the parameters you would like to save
into the Preset in a cleared(!) Layer. While holding down the
Alt / ⌥, select the desired Preset menu and the option Make
Preset... will be visible (Image 21). If you select this, you will
get a dialog where you can enter a name for your Preset and
set the 'Define on' options. If you have selected multiple
Fixtures, you can't select an option, the Preset will be saved
with you project for the selected Fixtures only. If you have
selected just one Fixture, you can choose to either save the
Preset for that Fixture only or to save the Preset to the
Fixture library file. This option means that the Fixture library
is altered on your computer, and that the Preset will be
available for all Fixtures of this type in this project, but in Image 21: Make Preset option
other projects as well. Only use this option if you are sure!
Your Presets are automatically given a quick select
sequence number when made.

Locking the Control panel
In some cases, it is useful for the Fixture controls to remain
visible while selecting other Fixtures on the stage (for Image 22: Make Preset Dialog
example, while dragging them around to order them). For
this, you can use the Lock View function. To lock the Control
Panel view, click the padlock button on the bottom right of
the Control Panel (Image 23). Now, whatever Fixture you
select, the locked view will stay in place. To unlock, use the
same button.

Image 23: The Lock View button
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6

Layer Control
As mentioned before, a key element of the LanBox is the principle of Layers. With Layers, you have a
very precise control of each Channel by carefully picking the Layers in which you activate Channels and
run Cues. This section will show you how to get most out of your Layers.

Basic control
Image 24 shows the basic controls of the LanBox Layers.
The Go button (A) will start the Cue List entered in the Cue
List Box (B). The Record button (C) will set the Layer to Edit
mode. The Deactivate Channels button (D) will make all
Channels in a Layer inactive and the Playback controls (E)
will enable you to Play, Pause and step through Cue Lists.
By clicking advanced... you open up the Advanced Layer
options, which will be covered later.

Layer Order
The order in which the Layers in a LanBox are ordered in the
end influences the Channel values and can therefore be
highly important. To change a Layer's position in the Layer
hierarchy simply drag it to the desired position. In LCedit+,
the Layers are represented in such a way that the highest
Layer has the highest priority. If two or more Layers have the
same Channels active, the upper most Layer determines the
actual Channel value.

Advanced Layer Options
Image 24: The basic Layer controls

When you open the Advanced Layer Options (the
advanced... button in the Basic Controls), a panel with extra Layer options appears. In this panel, we
have the following controls:
A Layer Option Buttons
B Manual Fade menu and control wheel
C Chase Mode menu and control wheel
D Layer Mix Mode menu and control wheel
E Add Layer button
F Layer ID
G Delete Layer button
H Layer Midi Show Control ID
I On-The-Fly Edit controls
All these controls will be covered in further sections of this
manual.

Image 25: The advanced Layer Options

Creating a new Layer
On standard boot, the LanBox-LCX has 5 Layers already initialized. In some cases this will be more then
enough, but in most cases it will be necessary to add more Layers. The LanBox-LCX can have a
maximum of 31 Layers. Adding a Layer is done by clicking the '+' button (E) in the advanced Layer
Options panel. A new Layer will be made and automatically placed on top. Note that the Layer does not
have an ID and all the Layers attributes are set to their default values. To set or change the ID, type it in
the Layer ID text box (F). A Layer ID can be A through Z, AA through AZ or BA through BK.
Note: a new Layer is not locked by default. The reason for this is to enable Cue Actions creating and also
deleting a Layer. If you want to save your Layer though when you save your LanBox data, it is necessary
to lock the Layer. Unlocked Layers will not be saved!

Layer Control
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Mix Modes
The Layer Mix Modes determine how overlapping Channels will be added up between Layers. The
LanBox has several ways of mixing the Layers, each of which with its own unique outcome. Only the
Transparent Mix Mode uses the Transparency value. When used well, these Mix Modes can be very
powerful tools, giving an extreme wide range of playback options for your show. Mix Mode and
Transparency Depth are adjusted with the Mix Mode Controls, D in Image 25.
Mix Mode: Off
None of the Channel values will be taken into account when determining the Mixer values, regardless if
Channels are active in the Layer.
Mix Mode: Copy
This is the knock-out mode. The Channel value of the top Layer will determine the Mixer value. All
Channel values in underlying Layers are overridden.
Mix Mode: HTP
HTP stands for Highest Takes Precedence. Only Channel values that have a value in this Layer that are
higher than (or equal to) values in underlying Layers are taken into account.
Example:
Channel:

Layer A (top): HTP

Layer B (bottom): copy

Mixer value

1

255

127

255

2

128

128

128

3

128

255

255

4

0

0

0

Mix Mode: LTP
LTP stands for Lowest Takes Precedence. Only Channel values that have a value in this Layer that are
lower than (or equal to) underlying values in underlying Layers are taken into account.
Example:
Channel:

Layer A (top): LTP

Layer B (bottom): copy

Mixer value

1

255

128

128

2

128

128

128

3

128

255

128

4

0

0

0
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pag. 17 / 68

LanBox & LCedit+ manual version 4.01
Mix Mode: Transparent
If a Layer is Transparent (Tsp), a percentage of the Channel values is added to (or subtracted from) the
values in underlying Layers. This percentage is determined by the Mix Mode Control Wheel which sets
the Transparency Depth. Mathematically, the Transparent function can be represented in the following
way:

Value=B+T∗(A− B)

where B is the base Channel value, A is the value in this Layer and T is the Transparency Depth. Note
that the ( A - B ) can also be a negative number, which would mean a subtraction!
Examples:
Ch.:

Layer A (top): Tsp 50%

Layer B (bottom): copy

Calculation

Mixer value

1

255

128

128 + 50% x (255 - 128)

191 (128 + 63.5)

2

128

128

128 + 50% x (128 - 128)

128 (128 + 0)

3

128

255

255 + 50% x (128 - 255)

191 (255 – 63.5)

4

100

200

200 + 50% x (100 – 200)

150 (200 - 50)

Ch.:

Layer A (top): Tsp 30%

Layer B (bottom): copy

Calculation

Mixer value

1

255

128

128 + 30% x (255 - 128)

166 (128 + 38.1)

2

128

128

128 + 30% x (128 - 128)

128 (128 + 0)

3

128

255

255 + 30% x (128 - 255)

217 (255 - 38.1)

4

100

200

200 + 30% x (100 - 200)

170 (200 - 30)

Mix Mode: Add
If a Layer is in Add Mode, it will perform a relative operation on the Channel values. It will add up the
value – 128 to the values in underlying Layers. This way you can have a 'home' value of a Channel set
and use relative values to adjust it. This is particularly useful when working with moving Fixtures, you can
make all movement of these Fixtures relative to a home position. The Add function uses the following
formula:

Value=B+( A−128)

Where B is the base Channel value and A is Channel value in this Layer. Note that the B – 128 can also
be a negative number, which would mean subtraction!
Examples:
Ch.:

Layer A (top): Add

Layer B (bottom): copy

Calculation

Mixer value

1

255

128

128 + (255-128)

255 (128 + 127)

2

128

128

128 + (128 - 128)

128 (128 + 0)

3

140

200

200 + (140 - 128)

212 (200 + 12)

4

100

200

200 + (100 – 128)

172 (200 - 28)

Chase Modes
Depending on the loaded Cue List, you can use different types of Chase Modes. What the difference is
between a Chase and a normal Cue List will be explained in the section Chases on page 28. If your Cue
List is a Chase, all functions described below will be applicable. If it is a Cue List with its own timing
programmed into it, it will mostly behave the same way, but some functions might give unexpected
results! The Chase Speed, controlled by the Chase Speed Control Wheel, determines the speed of the
Chase. It can be changed from 50% (half the speed) to Infinite. Infinite in practice means 0.05 seconds
per step, this is the maximum frame rate of the LanBox. Chase Mode and Speed are selected with the
Chase Mode Controls, C in Image 25.
Each LanBox Layer has the following Chase Modes:
Chase Mode: Off
No Chase. This does not mean the sequencer of the Layer is off, but it will follow the timing in the Cue
List.

Layer Control
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Chase Mode: Up (Loop)
The sequencer will step through the Cue Steps in normal order. If Loop is selected, it will return to the
first step of the Cue List after the last Step. If not, it will run the Chase only once and stop at the end of
the Cue List.
Chase Mode: Down (Loop)
The sequencer will step through the Cue Steps in reverse order. If Loop is selected, it will return to the
last step of the Cue List after the first Step. If not, it will run the Chase only once and stop at the
beginning of the Cue List.
Chase Mode: Random (Loop)
The sequencer will step through the Cue Steps in random order. If Loop is selected, it will start over if
every Cue Step has been shown once. If not, it will run the Chase only once and stop when every Cue
Step has been shown.
Chase Mode: Bounce (Loop)
The sequencer will first step through the Cue Steps in normal order, and reverse when the end is
reached. If Loop is selected, it will keep bouncing back and forth through the Chase. If not, it will step up
and down the Chase only once and stop at the start.

Manual Fade
The Manual Fade Mode and Time are used when, instead of a Cue List, Channel values are changed
manually, either by changing the Parameter values or by recalling Fixture Presets. Fade Mode and time
are adjusted with the Manual Fade Control, B in Image 25. The following Fade Modes are available:
Fade Mode: Off
No Fade, new values will be output instantaneously.
Fade Mode: Fade In
Only incrementing Channel values (values that are higher than the previous value) will be faded.
Decrementing values will be output instantaneously.
Fade Mode: Fade Out
Only decrementing Channel values (values that are lower than the previous value) will be faded.
Incrementing values will be output instantaneously.
Fade Mode: X Fade
The Cross Fade Mode. All new Channel values, either incrementing or decrementing, will be faded.
At Constant Rate (CR)
This influences the way 16bit Channels will be faded. Constant Rate will make transitions smoother, but
will make the overall Fade a bit less accurate.

Solo Mode
A special Function of each LanBox Layer is the Solo Mode. When switched on, only the values of the
Channels which are set to Solo will be output. The Solo Mode is switched on with the 'S' button in the
Layer Option Buttons (A in Image 25). A Channel is set to Solo using the red button next to the Channel
(the bottom one of the two small buttons left of the parameters in the Fixture Control Panel). By default,
this button is turned off. If it is switched on (and it lights up red), this means a Channel is set to Solo.
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Other Layer Options
In the Advanced Layer Options, there are a few more Layer Options and Functions to adjust or control.
Layer Option: Disconnect from mixer.
The left most button of the Layer Option Buttons (A in Image 25). When toggled On, this will disconnect
the Layer values from the Mixer. In other words, all Channel values in the Layer will be ignored when
calculating the Mixer values. All other functions of the Layer (Sequencing, Channel settings, Cue Lists
etc.) won't be effected by this and will be restored when the Layer is connected again.
Layer Option: Disable Fading
The Disable Fading Button is the second button of the Layer Option Buttons (A in Image 25). When
toggled on, it will ignore all fading information in the Layer, either Manual Fades or Fades in Cue Lists.
This means that all new Channel values will be output instantaneously. All Fade Settings are restored
when this setting is toggled Off.
Layer Option: Automatic Output Off
This is the fourth button of the Layer Option Buttons (A in Image 25). When toggled On, a parameter
which value is changed in the Layer its output won't be automatically be activated in the Layer. This way,
you can control manually which Channel value should be output and which shouldn't.
Layer Option: Locked
A Locked Layer doesn't mean that a Layer can't be changed, but it prevents a Layer from being deleted
either manually or by a Cue List. It also determines if a Layer will be stored when the LanBox Data is
saved.
Note: by default, a new Layer is never Locked. To make sure the Layer is saved though, you will have to
Lock it!
Delete Layer
The Delete Layer Button (G in Image 25) will remove a Layer. Be careful with this, you won't be asked for
a confirmation when deleting an unlocked Layer!
MSC ID
The MIDI Show Control ID (H in Image 25) sets the ID number of the current Layer. If you want to use
MIDI Show Control, each Layer you want to control should have a unique ID. This ID can be any number
in a range of 1 – 127. More information on MIDI Show Control is found in the section MIDI Show Control
(MSC) on page 49.
On-The-Fly Edit
On-The-Fly Edit (I in Image 25) can be used to edit Cue Steps without opening the Cue List in the Cue
List Editor. This function will be covered in the section On-The-Fly Edit on page 28.
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7

Cue Lists
Cue Lists are the most important way to control the LanBox and your Fixtures. Virtually every function of
the LanBox can be controlled through Cue Lists. There are several ways to create and edit Cue Lists
which will be covered in this section, as well as all the possible Cue List Actions.

Terminology
In order to understand this section, it is necessary to cover the terminology used in LCedit+ considering
Cue Lists. For that reason, we will start with a glossary of all the terms used.
Cue List
The overall term for a collection of Cue Steps. Each Cue List is stored in the LanBox and identified with a
number between 1 and 999. Every Cue List can contain up to 99 Cue Steps.
Cue Step
The smallest entity of a Cue List. This contains the Data to tell the Layer what to do. A Cue Step can
contain Channel values, but this does not always have to be the case, it can also just contain 'Scripting
Data'. If a Cue Step contains Channel values, it is called a Scene and the Channel values in the Cue
Step is called the Scene Data. The action information in a Cue Step is called the Cue Step Action. Each
Cue List should have at least one Cue Step.
Cue
A Cue consists of a number of Cue Steps separated by an 'Hold for ever' Cue Step Action. If there is no
such Cue Step Action in a Cue List, the Cue consists of the entire Cue List and will end with step .0 of the
next Cue List, which is a 'natural' Hold for ever Cue Step.
Chase
A Chase is a special kind of Cue List in such a way that it does only contain Scenes. It has no other Cue
Step Actions like Hold , Go to or Loop.

Creating Cues
There are two distinct ways to create and edit a Cue List, either through a Layer or by using Blind Edit.
Both ways have their own advantages and disadvantages and it is up to the user to figure out which way
is best in every case. (There is actually a third kind of Cue List editing, On-The-Fly Edit, but this is a more
special case and covered later in this section).

Cue Lists
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The Cue List Editor

Image 26: The Cue List Editor

When creating and editing Cue Lists, the Cue List Editor window will be your most complete and most
important source of information and interface. A Cue List Editor window automatically opens when you
open LCedit+, but you can also open a new Cue List Editor with Window → New Cuelist Editor in the
Menu (Ctrl Shift Alt + S / ⌘ ⌥ ⇧ + S).
In the Cue List Editor, you have a column containing the Cue Step Numbers, one with the Cue Actions
and a overview of all the LanBox Channels and their values. The numbers (A) indicate the Channel
numbers. Channels currently selected in the Stage or Cast Window will be highlighted in blue. The
Channels which have been assigned values somewhere in the Cue List will have a green/yellow
background in their value fields. With the | | symbol on the far right of the channel list, you can toggle the
view of the Channels from 'All Channels' to 'Focus', which will only display the Channels which have been
assigned values.
A Cue List is loaded by typing the number in the Cue List number box (B) and hitting Enter/Return or click
Load in the Cue List Edit buttons (C). The first of these buttons actually changes function depending on
the number entered in the Cue List number box. If the Cue List number entered is different from the
loaded Cue List, it will say 'Load' and load the new Cue List (you will be prompted if the current Cue List
is not stored yet). When the number is the same, it will say 'Reload' and will retrieve the stored Cue List
from the LanBox and undo all changes made to it in the Editor. Finally, if you clear the number box, the
button will say 'Clear' and present you with an empty Cue List. Loading Cue List 0 will do the same.
Alternatively, you can also click the black arrow next to the Cue List number box. This will display a menu
with all the currently stores Cue Lists in the LanBox. Selecting a Cue List will automatically load it into the
Cue List Editor.
The second button, 'Store', will save the Cue List to the number entered in the number box. If there is
already a Cue List stored with the same number, you will be prompted to overwrite. The 'Delete' button
removes the currently loaded Cue List from the LanBox. The 'Path' button opens the Path and Pattern
dialog which will be covered in the section Path and Pattern Generator on page 27.
With drop down menu D you can select the LanBox you want to edit Cue Lists on. This will only apply
when you are connected to multiple LanBoxes simultaneously. Drop Down menu E allows you to select
the way the Cue List Editor behaves. In Blind Edit mode, all Channel values are typed into the Editor.
You can also choose to Edit via a Layer (this Layer will have to be in Edit Mode, see next section) or to
Follow a specific Layer. When you Follow a Layer, the Cue List that is running in that Layer will be
automatically loaded and the current Cue Step highlighted. Editing of the Cue List is not possible in this
Mode, which will be indicated by the padlock symbol on the far bottom right (G).
By default, the Cue List editor displays numeric Channel values (0-255), but this can be switched to
percentages with the '%' button (F).

Cue Lists
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Editing using a Layer
The easiest way to create and edit Cue Lists, especially for
beginners, is to edit via a Layer. To be able to use a Layer
for editing, the Layer will have be set in Edit Mode (Image
27). This is done by clicking the red 'Record' button in the
Layer Controls. If no Cue List editor is opened, LCedit+ will
automatically open one with 'Edit via Layer .. ' selected as
Cue List Editor Mode. To start making a Cue List, load a Cue
List by typing the number in the Cue List Box (in Image 27,
we typed 15) and press Enter/Return or Play to load it. If the
Cue List does not yet exist, LCedit+ assumes you are
creating a new Cue List.
When a new Cue List is loaded, Cue Step 1 is automatically
selected. Now, if you select one or more Fixtures on the
Stage or the in Cast Window and change a parameter, you
will see those values appear in the Cue List Editor. The Cue
Step Action will be set to the last one used for a Scene Cue
Step, the default will be 'show scene for 5.1s, crossfading for Image 27: A Layer in Edit Mode
5.1s'. To change this, you can double click the Cue Step
Action to edit it. The possible Cue Step Actions will be covered in the section Cue Step Actions. If all
Channel values are to your liking, you can click the 'skip forward' button in the Layer Controls to go to the
next Cue Step. A soon as you change a Parameter value, a new Scene will be created, copying all
Channel values from the previous Cue Step (except for the parameter(s) you just changed). Repeat this
until you have the desired amount of Cue Steps and store the Cue List.
This way, you have created a Chase Cue List. You can run this Cue List by loading in into a Layer and
set it into a Chase Mode (see section Chase Modes, page 18). In order to have more control over your
Cue List, you will have to add special Cue Step Actions, which will be covered further on.
Blind Edit
If you select Blind Edit as Cue List Editor Mode, there is no Layer involved in setting the Channel values.
Instead, you type the values directly into the Cue List Editor's Channel value cells. This can either be in
decimal values (0-255) or percentages, depending on the setting. Deleting the contents of a Channel
value cell clears the Channel. In the Channel value cells you can copy/paste as if is were a normal
spreadsheet, select multiple cells using Ctrl and Shift / ⌘ and ⇧ and move through the cells using the
arrow keys on your keyboard. Selecting Fixtures on the Stage or in the Cast window will highlight the
selected Channels in the Cue List Editor.

Cue Step Actions
The Cue Step Actions you can set in a Cue List are the core of everything you can do in a Cue List. In
this section, we will go through the most important Cue Step Actions you will need to make normal
lighting Cue Lists and trigger other Cue Lists. More advanced Cue Step Actions will be mentioned here
as well, but be covered in more detail in the sections that cover their specific functions.
The Step Action Dialog
The Step Action Dialog (Image 28) is the main interface for
editing your Cue Step Action. It is divided in five main tabs.
Show will give you the basic Scene options, including fade
time and type. The options under Go are used to trigger Cue
Steps and Lists, as well as Loops and simple If/Then logical
operators. The Hold tabs sets wait options for your Cue List,
the Layer tab gives options to manipulate Layer properties
and the Special tab is used for Cue Step Actions that don't fit
any of the other categories.
Show Scene of this step
The most used Step Action for normal lighting Cue Steps. It
has the following parameters: the hold time, the Fade Type
and, if a Fade Type is set, a Fade Time. The Fade Time can Image 28: The Step Action Dialog
be set to 'fade at constant rate'. This influences the way 16bit
Channels will be faded. Constant Rate will make transitions smoother, but will make the overall Fade a
bit less accurate. If you use the Fade Types Fading in or Fading out, you have the option to Split the
Cue Lists

pag. 23 / 68

LanBox & LCedit+ manual version 4.01
Fade. With Split Fade activated, the Cue Step will ONLY Fade the values that are increasing/decreasing
(depending on the Fade Type) and ignore the other values. If it is not activated, the other Channels will
be set to the new value instantly.
Some examples of this Cue Step Action:
1 show scene for 1s
2 show scene for 1s, crossfading for 1s
3 show scene for 1s, crossfading for 0.5s
4 show scene for 1s

channel: 1
0%
100%
0%
100%

2
0%
100%
0%
100%

3
0%
100%
0%
100%

4
0%
100%
0%
100%

This simple Cue List will show the first scene right away (no
fade). The second Scene for a second, crossfading the whole
duration of the Scene. The third Scene will be shown for a second
again, only this time it will fade out for only half a second. Image
29 shows the actual DMX output.

Image 29: Cue Step Example 1

channel:
1 show scene for 1s
2 show scene for 1.0s, split fading out for 0.50s
3 show scene for 1.0s, split fading in for 0.50s
4 show scene for 1.0s, fading in for 0.50s
5 show scene for 1.0s, fading out for 0.50s

1
0%
50%
50%
0%
100%

In this example Cue List, the first Scene will be shown right
away again, but in the second Cue Step something special
happens. Because Split Fading is selected, only the Fade
Out is performed and the increasing Channel values are
ignored until the next Cue Step, where a Split Fade In is
selected. Note that in Cue Steps 4 and 5 Split Fade is
disabled, which return significantly different outputs (Image
30).

2
100%
50%
50%
0%
100%

3
100%
50%
50%
100%
0%

4
0%
50%
50%
100%
0%

Image 30: Cue Step Example 2

Show Scene of previous step
This Step Action does the same as the Show Scene of this step, except that is uses the Scene data from
the previous Cue Step. This can be useful when you want to use split fades (for example, first fade out
one set of lights, then fade in another set). Note that Scene Data can use up a lot of memory in the
LanBox, so re-using Scene Data can be a great asset when you are running short on available memory
in the LanBox.
Example:

channel: 1
1 show scene for 1s
100%
2 show scene for 1.0s, split fading out for 1.0s
0%
3 show prev for 1.0s, split fading in for 1.0s

2
100%
0%

3
0%
100%

4
0%
100%

In this Cue List, Channels 1 and 2 will first fade out in 1
second, before the other two channels will fade in (Image
31). This could also work the other way around, of course
with one set first fading in with the other fading out.

Show Scene of step .. (of cue list ..)

Image 31: Cue Step Example 3

To save memory in the LanBox, or to make a sort of custom presets which you can recall, you can refer
to Cue Scene data of any saved Cue List. This way, for example, you can make one Cue List with your
standard Channel values, which you refer to in other Cue Lists.
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Go to next/previous step (of layer)
These Cue Step Actions do exactly as the say they will do, go to the next or previous step. Not that
useful by itself, but could become a powerful control function if you target it to a different Layer. This will
perform a Step Forward or Step Back for the Cue List running in the targeted Layer.
Go to step ..
This Cue Step Action will perform a jump in your Cue List. This could be something as simple as an
infinite loop (see example), but will have countless uses in more advanced Cue List types. Notice that
when a Cue Step is referred to with a Go Action, the targeted Cue Step is marked with a > sign.
Example:

channel: 1
1>show scene for 1.0s, crossfading for 1.0s
100%
2 show scene for 1.0s, crossfading for 1.0s
0%
3 go .1

2
100%
0%

3
100%
0%

4
100%
0%

This Cue List will perform an infinite loop, fading Channels 1
through 4 in and out (Image 32).
Go to step .. of cue list .. (of Layer ..)
This Cue Step Action will load a Cue List at a certain Cue
Step in the current Layer if no Layer is selected, or in the
Image 32: Cue Step Example 4
targeted Layer if there is a Layer ID given.
Loop .. times to step ..
This will make the Cue List skip to the given Cue Step for a certain amount of times. Note that, if you
want to perform a sequence 4 times, you will only have to Loop 3 times (the sequence is already
performed once before the Loop Action is encountered).
Go to step if channel/input is within/outside
These Cue Step Actions perform a simple logic operation, checking a value of either a Mixer Channel or
an Analog Input and performing a Go Action if the conditions are met. This is used extensively in using
external devices for triggering events, like analog buttons/faders and external DMX sources. More on this
can be found in the sections covering those functions.
Hold step for ..
This Cue Step action pauses the execution of the Cue List for the time given. If the time is 'for ever', it will
effectively stop the Sequencer in the current Layer.
Hold until time/MTC is ..
This Cue Step Action will make the sequencer wait for a certain Time Index (either internal clock time or
MTC time) before proceeding. You have the choice between waiting until the time is after (or before) the
given time, or to wait for the transition. Use an x as time value to ignore this value (for example, x for the
day means it will be performed every day). Note that the days are counted 0 trough 6, with 0 being
Monday. More information on timing is to be found in the section Using Clocks on page35.
Clear/Suspend/Resume/Stop/Start/Reset Layer ..
These Cue Step Actions control a Layer. Usually this is done with another Layer, but is some cases they
can also point to the current Layer (for example, if you want to clear your Layer after executing the Cue
List). The Actions have the following results:
Clear: Sequencing will be stopped, the Cue List disconnected and all Channels will be deactivated.
Suspend: Pause a Layer. Sequencing in the Layer will stop immediately.
Resume: Resume a paused Layer.
Stop: Stops a Layer. The current Cue Step will be executed but the next Step will not.
Start: Starts a Stopped Layer again, beginning with the next Cue Step after when it was stopped.
Reset Layer: The running Cue List disconnected, but active Channels remain active.
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Set attributes to ..
This will control the three of the Layer Options: Disable Fading, Disconnect from Mixer and Set Solo. For
more details, see the sections Solo Mode on page 19 and Other Layer Options on page 20.
Set Mixer/Chaser to ..
These Cue Step Actions can control the Mix Mode settings and the Chase Settings of the current or
another Layer. For more information on these functions, see the sections Mix Modes on page 17 and
Chase Modes on page 18.
When setting the Mix Mode to Transparent or the Chase mode to any other setting than Off, you can also
set a value for this setting, and even set a fade time to go from one value to another.
Special: Comment
You can use Cue Steps to leave a comment. These Cue Steps will do nothing else. In the Cue List
Editor, comments are distinguishable by starting with a double dash --. a Comment can have a maximum
of 8 characters.
Special: Raw Command
For advanced users only. Every Cue Step Action is representable in 7 16bit bytes, which can be typed
here. For more information on the Cue Step Action binary data, please refer to the LanBox Reference
documentation.
Special: Write hex
This Cue Step Action allows you to send raw hexadecimal values to either the MIDI Port or one of the
Serial Outputs. More information on this you can find in the sections MIDI Out on page 50 and Using the
Digital Output as a Serial Port on page 56.
Special: Trigger
The Trigger Cue Step Action allows you to map a Channel value to 64 Cue Lists. Every Trigger should
have an unique ID (0-63), and can trigger 64 subsequent Cue Lists. The first of these Cue Lists should
be given when programming the Cue Step Action. Furthermore, the Channel to be Mapped should be
given as well as the Layer to start the Cue Lists in.
For example:
1 Tr 10 GoCue 501-564 OnCh 1024 in layer D
Means: 'Trigger 10: Go Cue List 501-564 On Channel 1024 in Layer D' and will map the value of Channel
1024 to Cue Lists 501-564. This is done by dividing the Channel value by 4, with the exception of course
that a value of 255 will start Cue List 564 (in this case).
Wait on step
The check box Wait on Step tells the Cue Step to wait for a Next Step command before proceeding with
the next Cue Step. This command can be given either by a Cue Step Action in another Cue List, or by
clicking the Play Button in the Layer Controls. The Wait on step attribute is marked in the Cue List Edit by
an exclamation mark (!) in front of the Cue Step Action.
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Path and Pattern Generator
In order to make it easier to make
certain paths for moving Fixtures or
patterns for vast arrays of lights,
LCedit+ comes with a Path and Pattern
generator. These make it possible to
quickly generate the Channel values
needed for complex movements or
patterns. To access the Path an
Pattern Generator, click the Path
button in the Cue List Editor (4th button
at C in Image 26). In order to use the
Path ans Pattern Generator, the Cue
List Editor should be set in decimal
mode, it will not open if the Cue List
Editor is set in percentage mode.
Path Generator
Image 33: The Path Generator

When opening the Path Generator, by
default a circle is displayed, or more accurately, an ellipse with equal x and y radius (Image 33). You can
select if you would like the pattern to apply for 16bit or 8bit movement (depending on your Fixtures and
the mode they are set in) by checking or unchecking the box next to P/T data. The box 'Steps' sets in
how many steps the movement should be divided. More Steps make the movement more accurate, but
also means more data to be stored in the LanBox.
With Path type you can select the shape you want to create. Here you can choose between Ellipse,
Lissajous (a sort of doubled sine wave) or Flower. The sliders set several parameters for the shape
generated. Try some different settings to see what happens.
Note that all movements do not take
into account the center point of a
moving head Fixture, so the circle
around the center would actually
become a figure 8. Again, try some
different movements to see what
actually happens.
To use the generated Path, click 'Copy
and Close'. The Channel values for the
Path will be copied to your computer's
clip board. Now you can paste them
into the cells in Cue List Editor at the
desired Channels. If you have chosen
16bit movement, 4 columns of values
will have been generated, with 8bit 2
columns. The movement Channel
values can be treated as normal Scene
Data. Add Show Scene... Cue Step
Actions to make the Cue List run Image 34: A Path copied into the Cue List Editor
(Image 34).
Pattern Generator
With the Pattern Generator (Image 35), you can quickly
create simply patterns for large arrays of lights. It works
largely the same way as the Path Generator. After
making the pattern, the Channel Data is copied to the
clip board and is available for pasting into the required
cells of the Cue List Editor. If you use multiple rows, the
Pattern Generator assumes that the Fixtures are number
left to right, top to bottom (so with a 12x3 grid, the top
row starts with channel 1, the second with 13 and the
third with 25).
Image 35: The Pattern Generator
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Manual Cue Action Editing
You do not necessarily have to open the Cue Step Action Dialog to edit your Cue List Actions. If you click
on a Cue Step Action while holding Ctrl / ⌘, you can edit the Cue Step Action by typing. You can type
the exact same text as the Dialog would generate, but there are some 'shortcuts'. For example, g 4.1 in b
will be translated by LCedit+ to Go 4.1in layer B. The most commonly used abbreviations are:
Go
show scene for
scene
in layer B
crossfading
channel
input
within
outside

g
show sc (for can always be left out)
sc
in b
xf
ch
in
wi
out

It is also possible to copy/paste complete Cue Steps (including Step Action en Scene Data), either by
using the copy and paste shortcuts or by Alt/ ⌥ dragging the Cue Step. Alt/ ⌥ dragging a Cue Step will
automatically insert an extra Step (and adjust Go Actions to point at the moved Steps if necessary).

Running Cue Lists
To run and test a Cue List, select the Layer you want to run the Cue List in and type the Cue List number
in the Cue List Box of the Layer Control (B in Image 24, page 16). If you only type the Cue List number,
the Cue List will start at the first step. If you add a Cue Step number (separated with a full stop), the Cue
List will start running at that Cue List. If you type a 0 (zero) as Cue Step number though, the Cue List will
only be loaded into the Layer, but not be executed.
With the Cue List controls you can manipulate the Cue List sequencing, by stepping forward and
backward, or pausing/resuming and stopping/starting a Cue List. If you start Cue List 0 in a Layer, this
will Reset the Layer. Note though that this only unloads the running Cue List, it does not clear the active
Channels. To do this, click the Clear button (with the eraser symbol, next to the Record Button), select
Layer → Clear Layer in the menu bar or press Ctrl Shift + C / ⌘ ⇧ + C.

Chases

Like mentioned before, a Chase is nothing more then a Cue List without Go Cue Step Actions. In order to
Play back a Chase, start it in a Layer as you would do with a normal Cue List. If the Layer's Chase Mode
it set to off, the Cue List will run once and be unloaded (the sequencer will actually stop at step '0' of the
next Cue List). To make the Chase Loop up, down, Bounce etc., set the Layer Chase Mode to the
desired setting. See section Chase Modes on page 18 for more information on Chase Modes.

On-The-Fly Edit
On-The-Fly Edit was the original way of creating and editing Cue Lists in the first types of LanBox. This
has been largely replaced by the Cue List Editor and most functions are not supported any more. The
only function that is still supported is editing the Cue Step Action parameters while a Cue List is running
in a Layer. To do this, click the On-The-Fly Edit box while the Cue List is running (the Layer must be in
Run Mode, not in Edit Mode). The Cue Step Action dialog for the current Cue Step will appear. Any
changes made in the Cue Step will be immediately stored on the LanBox.
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8

Running Shows
Once you have programmed all your Cue List, it is time to run a Show. LCedit+ and the LanBox give you
several options to optimize play back, which will be covered below.

Layer Information feedback
Every Layer active in the LanBox has a block in the Layer
Control panel giving you information on that Layer. It tells
you whether it is currently running a Cue List, which List and
Step it currently is running and if it is paused or not, what the
Layer is currently doing and which attributes are activated in Image 36: Layer information feedback
the Layer.
Layer State
The sequencer in every Layer can have the following states: Run, Stop, Paused and Wait.
Run means the sequencer is running a Cue List, using the timing of the Cue List. The current Cue List
and Step number are shown.
Stop means that no Cue List is running. It can be however that a Cue List is loaded but Run is
suspended. This will be shown as Cue Step number 0. Giving the Layer a Go command will set the state
back to Run
If a Layer is Paused, it has halted the sequencing of the loaded Cue List. This can also be mid-Step and
mid-Fade. If a Go command is given to the Layer, the Cue List will be (re)loaded, but the sequencer will
remain Paused.
Wait means that the Layer is waiting for a Next (or Previous) Step command before proceeding. A Go
command will cancel out this state and return the Layer to Run state.
Hold and Fade indicators
Underneath the Run State, two bars are displayed. These give the Hold and Fade Time of the current
Cue Step. As LCedit+ does not update real time, these numbers and bars are merely an indication, not
always the exact time.
Layer Attributes
At the bottom right of each Layer block, up to five icons display the Layer Attributes. From left to right
these are:
Output disabled: when this icon is visible, the outputs of the Layer are disconnected from the mixer.
Disable fading: when this icon is visible, fading in the Layer is disabled (both Manual and Cue Lists)
Solo Mode: when this icon is visible, the Layer is in Solo Mode.
Automatic Output: visible if the Layer Automatic Output is switched Off.
Layer Locked: This indicates if the Layer is locked or not.

Cue List information feedback
To see exactly what a Cue List is currently doing, there are two feedback options, the On-The-Fly Edit
information and the Follow Layer function of the Cue List Editor.
On-The-Fly Edit feedback
In the On-The-Fly Edit section of the Advanced Layer Options panel, the Cue Step Action of the current
Cue Step is visible. This way you have direct feedback of what is happening in the Layer.
Follow Layer
If you want more information on the currently running Cue List and Steps, you can set the Cue List Editor
to Follow a specific Layer (see page 22 on how to do this). The Cue List Editor will automatically load the
Cue List running in the Layer and highlight the current Cue Step. This will not only give you feedback on
the Cue Step Action, as well as show the Scene Data of the Cue Step.
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Channel information feedback
In order to monitor the actual values of your Mixer and DMX Channels, there are several possibilities: the
Stage, the Fixture Control Panel and the DMX Monitor.
Monitoring through the Stage
In order to monitor your Fixtures, you can change the view of your Fixture Icons to display their
Intensities, position (for moving lights) and color (for RGB Fixtures). See the section View options on
page 10 on how to do this.
Monitoring through the Fixture Control Panel.
When you select a Fixture (or a group of Fixtures) in your Stage, the Parameter values of the selected
Fixture(s) are shown in the Fixture Control Panel. Note that, if the parameters are active in the selected
Layer, the values given in that Layer will be visible (in black) but these won't necessarily be the actual
values (a Layer above can also influence those parameters). If the parameters aren't active in the
selected layer, the values will appear in gray and will show the current values.
The DMX Monitor
The most complete feedback for Channel values can be obtained via the DMX Monitor (Image 37). The
DMX Monitor can be opened with Window → New DMX Monitor or Ctrl Shift Alt + M / ⌘ ⌥ ⇧. With the
drop down menu on the left you can select what you want to monitor. You can choose to view the current
Channel values of either the Mixer, the DMX Output, the DMX Input, the Analog Inputs or any of the
Layers. With the '%' button you can switch between viewing numeric values or percentages. Recently
changed Channel values are displayed in red. Note that, in order to see Mixer Channels, these Channels
will have to be patched in your Stage.

Image 37: The DMX Monitor
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Show Automation
Although it is possible of course to start every Cue List manually, it is much easier to use some kind of
automation to start Cue Lists and set Layer Properties. An easy way to achieve part of this is to use a
system of master and slave Cue Lists. This means that you use one Cue Lists to control and trigger other
Cue Lists in other Layers.
For example:
In Layer A, you have the following Cue List running:
channel: 1
1 go 101.1 in layer AA
2 hold for ever
3 go 102.1 in layer AA
4 hold for ever
5 go 103.1 in layer AA
6 hold for ever
7 go 104.1 in Layer AA
8 hold for ever
9 go .1

2

3

4

Cue Lists 101 through 104 are 'normal' Cue Lists, setting lighting scenes. Now, you can simply use Next
Step in Layer A to start a Cue List in Layer AA. To keep things organized, it is recommended to keep
master and control Cue Lists and Layers connected. Like in this example, use Layer A to control Layer
AA, B to control layer AB etc. and use Cue List 1 to start Cue Lists 101 through 200, Cue List 2 to control
Cue Lists 201 through 300 etc.
A more complicated example:
Let us assume the following situation: we have a group of moving head Fixtures, whose movement
amplitude we want to control through an otherwise unused Channel (in this example, Channel 513).
We use Layer B to control Layer AB, which runs the moving heads Path Cue Lists. Layer AB though is
set to the Mix Mode Add (see section Mix Mode: Add on page 18) and we have a home fixed home
position set in an underlying Layer X (see table). Now, if we add another Layer (here BB) above that
Layer which contains the home position again but is set to transparent, we can control the movements
amplitude. In order to do this, Layer BB also runs a Cue List to check Channel 513's value and control its
Transparency.
Layer
Layer B
Layer BB
Layer AB

Mix Mode
copy
transparent
Add

Information
Runs Cue List 2 which triggers Cue Lists 21-30 in AB
Has the Home position for the moving heads set and runs Cue List 201
Runs Cue Lists 21-30 that control the movements. Because the Mix
Mode = Add, the movements are around the position set in Layer X

...
Layer AX
Layer X

copy
copy

Only used to control Channel 513
contains 'home values' for all used Fixtures

Cue List 2:

channel: 1

2

3

4

1>go 21.1 in layer AB
2 hold for ever
3 go 22.1 in layer AB
4 hold for ever
5 go 23.1 in layer AB
6 hold for ever
7 go 24.1 in Layer AB
8 hold for ever
9 go 25.1 in Layer AB
10 hold for ever.
11 go 26.1 in Layer AB
12 hold forever
13 go 27.1 in Layer AB
etc...
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Cue Lists 21-30 contain the data controlling the movements so everything works the same way as in the
first example. The big difference is in Cue List 201, running in Layer BB:
channel: 1
1>go .3 if channel 513 within 26 - max
2 set layer to mix transparent at 0%
3>go .5 if channel 513 outside 27 - 51
4 set layer to mix transparent at 10%
5>go .7 if channel 513 outside 52 - 76
6 set layer to mix transparent at 20%
7>go .9 if channel 513 outside 77 - 101
8 set layer to mix transparent at 30%
9>go .11 if channel 513 outside 102 - 126
10 set layer to mix transparent at 40%
11>go .13 if channel 513 outside 127 - 151
12 set layer to mix transparent at 50%
13>go .15 if channel 513 outside 152 – 176
14 set layer to mix transparent at 60%
15>go .17 if channel 513 outside 177 – 201
16 set layer to mix transparent at 70%
17>go .19 if channel 513 outside 202 - 226
18 set layer to mix transparent at 80%
19>go .21 if channel 513 outside 227 - 250
20 set layer to mix transparent at 90%
21 >go .23 if channel 513 within 0 - 250
22 set layer to mix transparent at 100%
23>go .1

2

3

4

What happens here: every frame, the Channel value 513 is checked by this Cue List. If this value is 255,
all 'If' statements are returned with a True. This means that the Cue List will skip to Step 3, then Step 5,
Step 7 etc. until it reaches Cue Step 21, where the Layer Transparency is set to 100% and the whole
Cue List is run again (go .1). This means that the Channel information in the Layer is completely ignored
by the LanBox Sequencer. If the Channel value is 90 however, the 'If' statement in Cue Step 7 is returned
with a False (90 is NOT outside 70 and 101). This means that, instead of skipping ahead to Step 9, Cue
Step 8 is performed, the Layer transparency is set to 30% and
the Cue List resumes again (returning True for every If
statement). This will result in a 70% smaller movement of the
moving head Fixtures relative to the position set in this Layer
BB, which was the home position.
This is just one example of the extensive possibilities of
scripting in the LanBox. Note that the Channel number (here
513) can be any Mixer Channel and that this Channel can also
be linked to an external Input, as we will see in later sections.

Using i-cue
If you want to change several parameter Channels at once, you
can use the i-cue function in LCedit+. When you press the i-cue
button, the Fixture Controls will be set in a 'Blind' Mode. This
means that any change you make to the parameters won't be
applied until the i-cue is applied. Note that the parameters
indicators on the left go blue when in i-cue mode. Clicking the icue button again or hitting space applies the i-cue, shift +
space / ⇧ + space cancels the i-cue.

Image 38: Fixture Controls in i-cue mode

Running Shows

pag. 32 / 68

LanBox & LCedit+ manual version 4.01

Keys and Macros
LCedit+ has a number of ways to make interfacing with and controlling the LanBox easier and faster. It
has several keyboard shortcuts to access certain functions, Command Line to quickly start Cue Lists or
select Fixtures and customizable Key Strokes to create shortcuts to specific functions.
Keyboard shortcuts:
General LCedit+ functions
Action
Windows
OSX
Action
Windows
OSX
New Project
Ctrl + N
⌘+N
Undo
Ctrl + Z
⌘+Z
Open Project
Ctrl + O
⌘+O
Copy selected
Ctrl + C
⌘+C
Close Window
Ctrl + W
⌘+W
Cut selected
Ctrl + X
⌘+X
Save Project
Ctrl + S
⌘+S
Paste
Ctrl + V
⌘+V
Print Window contents
Ctrl + P
⌘+P
Select All
Ctrl + A
⌘+A
Quit LCedit+
Ctrl + Q
⌘+Q
Auto update LCedit+
Ctrl Alt + R
⌘⌥+R
Save LanBox Data
Ctrl Shift + S
⌘⇧+S
Update LCedit+ now
Ctrl + R
⌘+R
Window Management
Action
Windows
OSX
Action
Windows
OSX
Open new Stage Window
Ctrl Alt Shift + T ⌘ ⌥ ⇧ + T Open new DMX Monitor
Ctrl Alt Shift + M ⌘ ⌥ ⇧ + M
Open new Control Panel
Ctrl Alt Shift + C ⌘ ⌥ ⇧ + C Open Cast Window
Ctrl + 0
⌘+0
Open new Cue List Editor
Ctrl Alt Shift + S ⌘ ⌥ ⇧ + S Cycle through windows
Ctrl + TAB
⌥ + TAB
Stage Window functions
Action
Windows
OSX
Action
Windows
OSX
Select All Fixtures
Ctrl Alt + A
⌘⌥+A
Duplicate Item(s)
Ctrl + D
⌘+D
Select Similar
Ctrl + T
⌘+T
Make Group
Ctrl Alt + M
⌘⌥+M
New Fixture
Ctrl + K
⌘+K
Layer functions (Only available if a Control Panel is selected)
Action
Windows
OSX
Action
Windows
OSX
New Layer
Ctrl Shift + N
⌘⇧+N
Go Previous Cue
Alt + ⌥+Delete Layer
Ctrl Shift + L
⌘⇧+L
Go Next Cue List
Alt + PgUp
⌥ + PgUp
Ctrl Shift + N
Ctrl Shift + C
⌘⇧+C
Go Previous Cue List
Alt + PgDn
⌥ + PgDn
Switch to Edit Mode
Ctrl Shift + E
⌘⇧+E
Go Next Cue Step
Ctrl + =
⌘+=
Grab DMX values
Ctrl + G
⌘+G
Go Previous Cue Step
Ctrl + ⌘+Copy Control Panel values Ctrl + '
⌘+'
Go Next Cue
Alt + =
⌥+=
Paste Control Panel values Ctrl + ;
⌘+;
General Actions
Action
Windows
OSX
Action
Windows
OSX
Select Next Fixture
Ctrl Alt + ↓
⌘⌥+↓
Move current Layer Down
Ctrl Shift + ↓
⌘⇧+↓
Select Previous Fixture
Ctrl Alt + ↑
⌘⌥+↑
Toggle i-cue Mode
i
i
Add Next Fixture to selection Ctrl Alt Shift + ↓ ⌘ ⌥ ⇧ + ↓ Select Go field Control Panel u
u
Add
Prev.
Fixture
to Ctrl Alt + ↑
⌘ ⌥ ⇧ + ↑ Select Intensity parameter v
v
selection
Field
Select Next Layer
Ctrl + ↓
⌘+↓
Select Pan parameter Field x
x
Select Previous Layer
Ctrl + ↑
⌘+↑
Select Tilt parameter Field
y
y
Move current Layer Up
Ctrl Shift + ↑
⌘⇧+↑
Show parameter Channel
Ctrl +
⌘+
number.
mouseover
mouseover
Go Field shortcuts
Action
Windows
OSX
Action
Windows
OSX
Increment Cue Step
↑
↑
Decrement 5 Cue Steps
Shift + ↓
⇧+↓
Decrement Cue Step
↓
↓
Go entered Cue List + Step Enter
Return
Increment 5 Cue Steps
Shift + ↑
⇧+↑
Go in new Layer
Alt + Enter
⌥ + Return
Fixture Control shortcuts (Only available in Fixture Control Panel)
Action
Windows
OSX
Action
Windows
OSX
Increment value
↑
↑
Apply Data
Enter
Return
Decrement value
↓
↓
Cancel Data entry
Esc
Esc
Increment value by 10
Shift + ↑
⇧+↑
Activate all parameters
Alt + Enter
⌥ + Return
Decrement value by 10
Shift + ↓
⇧+↓
Deactivate all parameters
Alt +
⌥+
Backspace
Backspace

Running Shows

pag. 33 / 68

LanBox & LCedit+ manual version 4.01
Command Line Interface (CLI)
A lot of functions of LCedit+ that would otherwise require multiple mouse
clicks, are quickly accessible through the Command Line Interface (CLI).
The CLI is activated automatically if one of the Command Keys is pressed
(Image 39) and the command is applied with Enter/Return. To execute more
than 1 Command, separate the commands with a ; (semicolon). The Image 39: The Command
Line Interface
following Commands can be used:
Key Function
Go
g

k

Select Fixture

l

Select Group

m
n
p

Run Macro
Select Layer
Select Preset

r
s

Repeat last Command
Set Channel

Example
g10.1
g301a
g1af2
k70
k1-10
K17,19,21
l3
l1-2
l8k101-116
m5,6
nx
pc3
po1
ps7pb5,8
s127=255
s1-16f=0
S27-36,41-48ab=20

Start Cue List 10.1 in current Layer
Start Cue List 301 in Layer A
Start Cue List 1 in Layer AF of Interface 2
Select Fixture {70}
Select Fixtures {1} through {10}
Select Fixtures {17}, {19} and {21}
Select Group <3>
Select Groups <1> and <2>
Select Group <8> and Fixtures {101} through {116}
Run Macros 5 and 6
Select Layer X
Select Color Preset {3}
Select Other Preset {1}
Select Shutter Preset {7} and Beam Presets {5}| and {8}
Last Command is re-entered to be edited or executed again
Set Channel 127 to 255 in current Layer
Set Channels 1 through 16 to 0 in Layer F
Set Channels 27-36 and 41-48 to 20 in Layer AB

Keystroke Editor
With the Keystroke Editor you can create your own keyboard
shortcuts in LCedit+. These shortcuts will be saved with your
project. To add shortcuts, first open the Keystroke Editor
(Tools → Keystroke Editor..., Image 40). Press the keyboard
combination you would like to create a Keystroke shortcut for
and add the Command Line Interface Command to link to it.
Be aware that the Keystroke Editor does not check if
Keystrokes are already used for other functions. Check
above tables to see if they are!
Command Macros
Command Macros are a recorded sequence of LanBox
Image 40: The Keystroke Editor
commands. This means that you can save a series of
commands and recall them whenever you want. To start
recording a Command Macro, select Tools → Record Macro in the menu. Now you can do all the things
you would like to record. Note that not the mouse clicks and/or Keystrokes are recorded, but only the
actual Commands that are sent to the LanBox. This means that, for example, anything you do in the
Stage Window (which isn't stored on the LanBox) will not be recorded! When you have performed all the
actions you would like to save, select Tools → Stop Record to end the recording. When you do, you will
be asked for a name for the Command Macro.
To run a Command Macro, select it in the Macro list by
turning the Command Macro selection wheel in the Control
Panel (Image 41) and click the Run button. Alternatively,
you can also use the CLI command m followed by the Image 41: The Command Macro interface
Command Macro number.
To remove Command Macros, select Tools → Delete Macros... in the Menu and select the Macro(s) you
want to remove.
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Using Clocks
The LanBox has an internal Clock that allows you to synchronize Cue Lists with the time. As the LanBox
does not have an internal power supply, the actual time is not remembered when the LanBox is powered
off, and will be reset every time you boot. There are a few ways however to set the time.
Using the internal Clock
By default, when you boot the LanBox, the internal Clock will
be reset to Monday, 00:00:00.00. It is possible though to
adjust the Clock. In the Global Settings (Tools → Global
Settings...), under the DMX tab, you can find the Clock
Settings (Image 42). Here you can assign 6 Mixer Channels
to the internal Clock. By doing this, you achieve three things:
Image 42: The LanBox Clock Settings
you have created an interface to monitor the Clock, you can
adjust the Clock using these Channels and on boot, the LanBox now resets the time to the value these
Channels have when the LanBox Data is saved. To make it easier to monitor the Clock, LCedit+ has a
Clock Fixture in its Fixture Library (under Generic).
The Clock frequency tuning is used to fine-tune the internal Clock. Because the processor does not have
an exact number of 'ticks' per second, it is possible that the Clock might be about 1 second 'slow' every
day. Although this isn't much, it might accumulate over time. To Clock frequency tuning corrects this. For
the LanBox-LCX, the best tuning is 0.9998259 (0.9963220 for the LCM, 0.9970608 for the LCE).
The 6 Channels that can be assigned to the Clock have the following content:
Channel 1: Day Number (0 – 6 where 0 is Monday)
Channel 2: Hours (0 – 23)
Channel 3: Minutes (0 - 59)
Channel 4: Seconds (0 – 59)
Channel 5: Frames (0-29)
Channel 6: Frames/seconds, fixed at 30
With the Channels assigned to the Clock, it is possible to manipulate the Clock through Cue Lists. For
example, we can set the following Cue List to run right after boot:
channel: 3001
1 -- setclock
2 show scene for 0.05s
3 clear layer
4 hold until time x:09:00:10:00
5 go 201.1 in layer A
6 hold until time x:09:01:00:00
7go 202.1 in layer A

0

3002

3003

3004

3005

9

0

0

0

3006

This will set the internal Clock to Monday, 9:00:00.00 and wait for 10s before executing the Cue List in
Layer A (the x means the day data is ignored, so it will run every day. This can be used for the hours,
minutes and even seconds as well). After this, the Cue List will wait for 9:01:00.00 before starting the
next Cue List in Layer A.
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Using NTP
If the LanBox is connected to a network and/or the internet, it
is possible to have the Clock synchronized with a Network
Time Protocol (NTP) Server. The address of this server can
Image 43: NTP settings
be set in the communication (comm) tab of the Global
Settings (Tools → Global Settings..., Image 43). Nearly every system has an NTP server built in, as well
a lot of internet routers/modems. In OSX and most Linux systems the NTP server is switched on by
default, on Windows systems it needs to be switched on. To do this, open the regedit program and
locate:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpServer\
In the right pane, right-click Enabled, click Modify and set the value data to 1. Close regedit and either
restart the system or restart the Windows Time Service by typing the following command in the Windows
command prompt: net stop w32time && net start w32time.
If you have no NTP server on your network but you are connected to the internet, you can also use an
NTP server on the internet. Usually, your ISP has one on ntp.<isp name>.<domain>.
Note that the LanBox updates its time every 10 minutes. This can be seen as flooding/abuse by some
public NTP services!
To set the LanBox to use an NTP server, fill in its IP address in the NTP settings. Url's are not supported,
it has to be an IP address. NTP is always sent as UTC (Coordinated Universal Time), so you will have to
correct the time for your timezone and summer/daylight saving time. This is done in the Zone box. The
correction is typed as ±hhmm, where ± is the + or the – of your time zone, hh are the hours and mm the
minutes. So for Western Continental Europe the correction is +0200 in summer time, +0100 in winter and
for USA West Coast it is -0400 in summer and -0500 in winter.
In the Cue Step Action Dialog, you can select the option 'locked time' in the Hold tab. This means that
only NTP confirmed time is observed.
Using MIDI Timecode
An alternate way of synchronizing the LanBox time is by using MIDI Timecode (MTC). The LanBox will
only accept the so called quarter-frame messages, SysEx full-frame messages are ignored. As with the
normal time, the MTC time can be linked to Mixer Channels as well. This is also done in the Global
Settings (Tools → Global Settings...) under the DMX tab (Image 42). The only main difference with the
normal time is that MTC has a choice of frame rates. The possible frame rates are: 24fps (standard for
film), 25fps (PAL video), 30fps (non-drop NTSC) and 30fps Drop Frame (drop frame NTSC).
In the Step Action Dialog you have the option only to use 'locked' MTC. This means that the LanBox will
ignore inconsistent or erratic MTC messages.
Timed Cue List Example
channel:
1>-2 Hold until locked time before x:18:00:00:00
3 Hold until locked time before 5:00:00:00:00
4 Hold until locked time after x:09:00:00:00
5 go 90.1 in layer B
6 Hold for 15m
7 go .1
This Cue List will do the following:
First, it will wait until the time is before 18:00, which means that it will wait if the time is between 18:00
and 0:00. After midnight it will proceed to the next Step and check if it is a week day (day 5 = Saturday).
If it is Saturday or Sunday, it will wait until it is Monday (day 0), which is before day 5 again. Finally, it will
check if it is after 9:00 in the morning and if it is, run Cue List 90.1 once in Layer B. It will then wait for 15
minutes before it starts over again. So what it actually does in the end is start Cue List 90 every 15
minutes, Monday till Friday between 9:00 and 18:00.
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Using external triggers
There are quite some possibilities to control the LanBox using external controls. These are all so
extensive that they are covered in their own sections. The possible external inputs are:
MIDI Notes, section Note-On and Note-Off, page 47
MIDI CC messages, section MIDI Control Change Messages, page 48
MIDI Show Control, section MIDI Show Control (MSC), page49
DMX Input, section Use DMX Input values, page 51
Analogue Inputs, section Using Analog Inputs as trigger, page 55
UDP Channel values, section Receiving Channel data, page 58

IR remote control
This section only refers to the LanBox-LCE and LCM. The LanBox-LCX does not have an Infrared
sensor.
In order to use a remote control, you will first have to perform a setup for the remote control. The
following protocols are supported:
Sony, 12, 15 and 20 bits
Philips, RC5 and RC6
NEC, most protocols
The IR keys can be custom mapped to a LanBox command. The LanBox can save two IR Key Maps. By
default, Key Map 1 is the Apple Remote, Key Map 2 is the Sony RM-V202.
Mapping the IR Keys
Press any key on the remote except the power or menu key. The LanBox will display NEC, RC5, RC6 or
Sony if it recognizes your remote control. Press the Power (or Menu) button 3x short, 1x long, 3 times
short to enter the Setup (Short is shorter then ¼ second, long 1 second). The display should say IR1
when the sequence is recognized. Press the Power button again (within 5s) to toggle between the Key
Mapping of IR1 and IR2.
Now, the LanBox Display will go through all the Key Commands. For each command, press the
appropriate button an the remote control. If you want to skip a command, press the Power button. After
the last command, the LanBox will return to its normal mode and a Cue List (number 999) is created
which contains all the commands. This will not be saved though until you save the LanBox Data. This can
be done with LCedit+ or with the remote control button assigned to 'record'.
Using the IR controls
If the LCE/LCM is in the Home menu, the display will show '----' (if the LCM boots in MIDI mode, it will
show '====' in the display). You can switch to any menu item from the Home menu by pressing the
corresponding number (see the table below). The display will briefly show the name of the item followed
by its value. When there are multiple items, you can cycle through them by pressing the number again.
The Power button toggles between the Home menu and item 5, Layer/Cue Lists.
To edit a value in a menu Item, press the Play button. The value will blink to indicate that it is in edit
mode. Use the number buttons or the up/down buttons to enter a new value and apply with the Play
button (or cancel with the Power button). Note that, when using the number buttons, you will always need
to include the leading zeros (so 005 for 5%).
All edited values are not stored permanently until you store the LanBox Data.
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IR Menu Items
Button

Item

description

Shortcuts

1 Load

Load a Cue List and Step.

Fast forward

Next Cue

Rewind

Previous Cue

2 Store

Save the current Scene

3 Fade Time

Set the Fade Time to be stored with 'Store'

Fade Type

Set the Fade Type to be stored with 'Store'
0 = No Fade, 1 = Fade In, 2 = Fade Out, 3=
Cross, 4 – 7 = Constant Rate of 0 – 3.

4 Hold Time

Set the hold Time to be stored with 'Store”

5 Play

Play back Cue Lists. Use up/down to change Stop
Layer.
Pause

6 Speed
Mode
7 Start Ch.

Pause Sequencer

Change the Chase Speed of the Layer selected
in 5
Change the Chase Mode of the Layer selected
in 5
Set the Start Channel of the range of Channels Fast forward
you want to view or set
Rewind

8 End Ch.

Set the End Channel of the range of Channels Fast forward
you want to view or set

9 value

View or Set the value of the Channels set with Up/Down
menu items 7 and 8. Channels are enabled
when set. Disable the Channels by setting a
negative value. Only enabled Channels are
stored with item 2.

Rewind

Stop
0 Configure

Stop sequencer

Next Channel
Previous Channel
Next Channel
Previous Channel
Change value

Disable selected
Channels

Press Play, then a 4 number code followed by
Play again to enter a Configuration item. The 2
items are:
0001: Toggle between Next/previous Cue or
next/previous Step for the Next Cue command
9172: Erase All LanBox Data. Press the Record
Button for 10 seconds.
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9

Fixture Definitions
This section will cover viewing, managing and editing the Fixtures in the LCedit+ Library.

Fixture Library
LCedit+ comes with a Library that contains most common
Fixtures from the leading manufacturers. The number of
manufacturers and product is growing every day though and
it is impossible to keep it complete and up to date. That is
why you can edit and make your own Fixtures in LCedit+.
To open the Fixture Library, select Window → Library Editor.
The Library Editor Window (Image 44) will show a List of all
the Fixtures currently in the Fixture Library. Double-click an
item to open the Fixture Definition Dialog.
Image 44: The Library Editor Window
The Fixture Definition Window (Image 45) by default opens in the Design Tab. Here you can view the
different controls and the corresponding Channels. All the Fixture Parameters are divided up in 'panels'.
These are the controls you see in the Fixture Control Panel. There is no theoretical limit to the amount of
Parameters and Controls you can assign to a Fixture, but screen size is a limitation. If a Fixture definition
has so many controls that it won't fit on the screen, consider leaving away controls you don't use or
choose more compact control interface methods (a small wheel instead of a large wheel, or a wheel
instead of buttons).

Editing a Fixture
Note that the Fixture Library is shared by all you project files. Changing a Fixture Definition will effect
other projects as well!
To change a Fixture control, select the control in the list in the Fixture Definition Dialog. The lower half of
the dialog will show the Control Interface type, the way the Channel information is displayed (decimal,
hexadecimal or percentage), the Control Label (the name displayed above the Control) and the Channels
the control applies to. The Channel number is an offset! This means that the 1st Channel of a Fixture will
have Channel 0, the 2nd 1, etc.
The order of the Controls determines the order in which they appear in the Fixture Control Panel. Use the
Move up and Move down buttons to change the order. The top Control must ALWAYS be a large wheel
named Intensity! This is even the case if your Fixture doesn't actually have a master Intensity. In this
case, leave the Channels blank. This is to ensure correct behavior of the Fixture Controls when they are
grouped. The separator option determines if a separating line is displayed above the Control. The Delete
button will remove the selected control from the list and therefore from the Fixture Control Panel.
The Iconstrip button opens a dialog which
assigns icons to specific Channel value
ranges. More on this in the next section.'
An edited Fixture Definition is automatically
saved when the dialog is closed with OK.
When closed with Cancel, all changes will be
discarded.

Image 45: The Fixture Definition Window
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Creating a Fixture
In order to make a new Fixture, it is always advisable to have a DMX table/chart of the Fixture. This is
usually printed in the Fixture Manual. If the Fixture is similar to an already existing one, you can duplicate
that Fixture and edit it, or you can make a new one from scratch.
To duplicate an existing Fixture, select Edit → Duplicate Item in the menu, to create a new Fixture, select
Edit → New Fixture. The Library Editor should be the active Window to perform either of these actions.
Below, only the creating of a new Fixture will be explained, as it will cover all the elements you would
need to edit or duplicate a Fixture as well.
Making a New Fixture
When creating a New Fixture, a new, empty Fixture
Definition Window will appear. First, give the Fixture a
name. We have chosen to make a Fixture Definition
for the Robe ColorSpot AT in this example, all the
information we use for the Fixture is obtained from
www.robe.cz. The normal name can be the full
description of the product, the short name should be
as short and compact as possible but still be
descriptive enough to identify it on the Stage (as this
is where the short name will be used). We found the
DMX chart for the Fixture on the Robe website (see
Appendix I: ColorSpot 250AT DMX chart), and we
have chosen to use mode 1.
Master Intensity
The first control to add is the Master Intensity. To add
a control, click in the (now empty) Controls List and Image 46: New Fixture Definition Window
select Large Wheel from the top left drop down menu.
Label the Control Intensity and assign the appropriate
Channel Offset (in this case Channel 16). Because the
Intensity of this Fixture is 16bit, we could have chosen
a 16bit Wheel, but because of before mentioned
Grouping behavior we don't. Instead, we will add a
Small Wheel which we will label Intensity fine and
assign it Channel 17. Because these two controls
belong together, we leave out the separator above this
control. We give both controls a Percentage property
(Image 47). One consequence of splitting these
Controls is that the LanBox will not recognize these
two Channels as one 16bit control. If you do want to
use the 16bit functionality however, there is still a
solution for this which is covered in the section 16bit
Table on page 46.
Pan Tilt Control
The next Control to add is the Pan Tilt Control. For
these parameters, LCedit+ has the Trackball Control. Image 47: Intensity Controls added
Click in an empty part of the Controls list again and
add a Trackball 16bit by selecting it in the Control drop down menu. Label it Pan Tilt and assign the
appropriate Channels (0-3 in this case). Because it is a group of Channels, the first and last Channel of
the group are typed, separated by a dash. You can also type the different Channels separated by
commas (0,1,2,3). Leave the separator checked.
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Wheel with icons: Color and Gobo Wheel
The next control is a more complicated one, the Color Wheel. There are several ways to add this control.
We can choose to just add a wheel, but this will not give us any indication of which color we have
selected. We could also add Buttons, this gives direct access to the different colors, but lacks the
possibility to scroll the colors but will allow steps. The best choice here seems to be a Wheel with Icons.
We achieve this by clicking an empty part of the Controls list again and adding a 16bit Wheel (this
Fixture in this Mode has 2 Channels for the Color, which makes it 16bit). First, we Label the Control again
(Color) and assign the Channels (6,7), but
then we hit the Iconstrip... button. This opens
Image 48: The Color Icons for the Robe ColorSpot 250AT
up the Edit Icon Strip dialog for this control.
Icons in the LCedit+ Fixture Library are made up by a series
of 16x16 pixel icons, placed in a line (Image 48). The Robe
ColorSpot 250AT has 27 possible settings for the Color
Wheel, so we need 27 icons. This makes that the Icon Strip
image will be 27x16=432 pixels wide (and 16 pixels high).
The LCedit+ package contains an example Icon Strip. Note
that the 16x16 pixels Icons are used for the 'large' icons next
to the Large Wheel. For the Small Wheel and Buttons, 12x12
pixel Icons are used.
You can make the Icon Strip with any software you prefer,
save it and drag the file into the Edit Icon Strip dialog.
LCedit+ will automatically distribute the Channel value over
the Strip but in this case we don't want that. If we look at the
DMX chart, we can see that on the values 0-128, the colors
aren't steps but 'proportional', which means that it is a
Image 49: The Edit Icon Strip dialog
continuous scroll. The way to apply this is as follows:
Select the first (white) icon. We set it to be active between
Channel 0 and 0, but check the 'Continuous' box. This
makes this Icon and the next one to scroll. Note that it now
says that it in continuous from value 0 to the high value of
the next icon. We repeat this for the whole first series of
Icons, up until the second white Icons. After this, the DMX
Chart tells us that the next colors are all 'Step', which means
that it will snap to a color if the DMX value is in the specified
range. So, for the next cycle of colors, we leave the
Continuous box unchecked. Just fill in the correct start
(should be filled in automatically) and end value for each
color Icon.
If we arrive at the Rainbow effects, the Chart states them as
proportional again, but actually they are not Continuous in
the sense as we use it. The DMX value in the range does
influence the Effect speed, but the Icon should remain the
same. This is why we do not us the Continuous function
here. In the end, the Icon Strip should look like Image 50.
Note that there are also button numbers displayed in the Icon
Strip Dialog (Btn), but these are not used right now and will
be covered when we're making buttons.
The Gobo Wheel will be roughly the same as the Color
Wheel, although the Gobo control is only 8bit, which allows
us to use a normal Large Wheel on Channel 8. Again, we
attach an Icon Strip, but it is a bit larger this time. The DMX
Chart shows us that there are a total of 35 different
possibilities for the Gobo: Static Gobo, Rotating Gobo, Image 50: Complete Color Icon Strip
Shaking Gobo, Rotating and Shaking Gobo as well as some
cycling functions. Again, we have made an Icon Strip (Image 51, the Gobo graphics we found on the
Robe website) and assigned the correct DMX values. This time, no continuous values are needed at all.
For the Gobo Indexing/Rotation we add a 16bit control labeled Gobo Index on Channels 9,10 (without
separator). Note that we also could have made buttons for this Parameter, but with 35 different settings, it
would take up a lot of space in the Fixture Control.
Image 51: The Robe ColorSpot 250AT Gobo Icon Strip
Fixture Definitions
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Buttons with icons: The Prism and Shutter
The Prism Parameter has no proportional
functions, so it is ideal for buttons. Again, we Image 52: Prism Icon Strip for the Robe ColorSpot 250AT
make an Icon Strip (Image 52) with 14 icons
(open, prism and 12 macros). In the Fixture Definition Dialog we
add a Buttons Control, assign Channel 11 and label it Prism.
Now we add the Icon Strip by clicking the Iconstrip... button and
adding the Icon Strip Image. Now we set all the Channel values
to match the DMX chart and end up with what's shown in Image
53. After this we add a Small Wheel control for the indexing and
rotation of the Prism.
If we look at the Shutter function in the DMX Chart, we see that
there are 9 settings, but that the No Function (shutter open) is
repeated 4 times. We only need it once though. The way to
handle this is to make a normal Icon Strip 9 Icons wide as
shown in Image 54. Note that there are a few black Icons in
there. These were added because we are not planning to
actually use them for a button. In the Edit Icon Strip Dialog, it is
possible to assign another button number to each Icon. If you
assign Button 0 (zero), the Icon won't be used at all. So in case Image 53: Edited Icon Strip for the Prism
of the Shutter Function, we assign a 0 to Icons 4, 7 and 9, the control
duplicates of the No Function setting and the black Icons in the
Strip (Image 55).
Image 54: Shutter Icon Strip

Other functions
In order to finish the Library File for this Fixture, we add the last
Controls: a 16bit wheel for the Focus on Channels 13,14, an
extra set of buttons for the Fixture Power/Function Parameter
and a small wheel for the Pan/Tilt Speed. In the end, out Fixture
Definition looks like Image 56. Clicking OK automatically saves
the Definition, clicking Cancel will discard any changes made.
As a finishing touch we give the Fixture a nice Icon as described
in the section Changing your Fixture icon on page 11.
When closing the Definition Editor for a Fixture for the first time,
LCedit+ will ask where to save your Definition File. The file
should always be saved in the Library folder in the LCedit+
folder. The name of the sub folder determines the manufacturer Image 55: Edited Shutter Icons, 0 = not
name in the Fixture Library. Make sure that the file name is a used
unique name!

Image 56: The Finished Fixture Definition
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Creating Presets
To make control over your Fixtures easier and quicker, you
can add Fixture Presets to your Fixture. These are saved
with the Library file, so they will be available every time you
use the Fixture. To create Fixture Presets, select the Presets
tab in the Fixture Definition window (Image 57). To make a
Preset, first select one of the Preset categories, then click in
an empty part of the Preset field below the categories field
and give a name in the text box below. When a name is
given, an empty Preset will be made, Now, select this Preset
and one by one, select the parameters which you want to
control with this Preset (and only those parameters, leave
the ones you don't want to control empty) and give them the
appropriate value. For example, to make a Full Preset, select
the Shutter category, click in the Presets field an give the
new Preset the name 'full'. Now select the Intensity
Parameter and give it a value of 255. The Presets are
automatically saved with your Fixture definitions.

Image 57: The Presets tab

Updating the Fixture Library
When making a new Fixture Definition, you probably want to see what it will look like now and then.
Although the Fixture definition is saved automatically, you will have to reload the Fixture Library before
LCedit+ will use the new Definition.
To do this, select File → Extra → Reload Library in the menu. This will reload all Fixture Definitions and
replaces all used Definitions with the newly loaded ones.

Importing Fixtures
To import a Fixture Definition into LCedit+, simply copy the Library file into the Library folder of LCedit+.
You will have to make sure that the both the file name as well as the Fixture name are unique.

Fixture Definitions

pag. 43 / 68

LanBox & LCedit+ manual version 4.01

10 Patching and Channel properties
The LanBox-LCX had 3072 Mixer Channels which can all be patched and be
assigned properties. This section will cover all these possibilities. The Channel
Properties and Patch are edited with the Patch Editor (Tools → Patch Editor...).

Patch Table
Every Mixer Channel in the LanBox can be assigned to any DMX Channel. It is
even possible to assign a Mixer Channel to multiple DMX Channels. To edit the
DMX Patch Table, open the Patch Editor. The default view of the Patch Editor
window is the DMX Patch (Image 58). The DMX Patch table is essentially a list of
512 Channel pairs. The first number is the DMX Out Channel, the second number
is the LanBox Mixer Channel. A DMX Channel is patched to a Mixer Channel by
selecting the DMX Channel number in the list and typing the appropriate Mixer
Channel number in the 'Set to' number box at the bottom of the list.
To patch Multiple DMX Channels to the same Mixer Channel, you can select
multiple Channels at once by dragging the mouse or holding Shift/⇧ to select
Channels that are grouped together or hold Ctrl/⌘ to select multiple Channels that
aren't grouped (Ctrl + A / ⌘ + A selects all Channels). Now, when you enter a
Mixer Channel in the 'Set to' box, all selected DMX Channels will be assigned that
Mixer Channel. To let LCedit+ auto increase the Mixer Channel numbers, select
the ' | ' button next to the 'Set to' box. This will automatically increase every next
Channel with 1. Click the ' | ' button again to turn auto increase off.
The DMX Patch Table is not stored in the LanBox until you click the Store Button,
and it won't be permanently saved until you save the LanBox data.

Gain

Image 58: The Patch

Before DMX values are sent by the LanBox, they are multiplied by a Gain Factor. Editor Window
This Gain is completely independent from Layers, Cue Lists and any other
processing of the LanBox. The LanBox calculates the Channel value using the
following formula:

Output=

Gain
∗Mixer Value
128

So a Gain Factor of 128 (default) will multiply the Mixer value by 1 (so leaving it
the same), a Factor of 0 will make it 0 and a Factor off 255 will double the Mixer
value.
The Gain Factors of the DMX Channels can be set by opening the Patch Editor
and selecting Gains from the drop down menu. Changing a Gain Factor is done by
selecting one or more DMX Channels and setting the Factor in the 'Set to' box.
Although rarely useful, the auto increase function (activated with the ' | ' button)
can also be used when setting the Gain. The Gains Table is not stored in the
LanBox until you click the Store Button, and it won't be permanently saved until
you save the LanBox data.
Master Intensity Control
The Master Intensity Control in the Fixture Control Panel (Image 60) also sets the
Gain Factor of the selected Fixture. Note though that this applies to the DMX
Channel linked to the Mixer Channel of the selected Fixture and therefore applies
to ALL Layers! For this reason, it (obviously) isn't possible to set a master intensity
of Fixtures/Channels that aren't patched to a DMX Channel.

Image 60: The Master Intensity
Control

Image 59: The
Channel Gains
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Curves
Not every Fixture responds linearly to DMX values (for example, a lot of LED lights
are already at 50% of their intensity at a DMX value of only 25 ≈ 10%). For that
reason, the LanBox has the possibility to change Curve of every DMX Channel.
There are 8 possible Curves, numbered 0 through 7 where, by default, 0 is the
linear 1:1 Curve which cannot be changed. All the other Curves though can be
customized. Every Curve is a list consisting of all 255 'input' values accompanied
by an output value.
Assigning Curves
The Curves of the DMX Channels can be set by opening the Patch Editor and
selecting Curves from the drop down menu (Image 61). Changing a Channel
Curve is done by selecting one or more DMX Channels and setting the Curve
number in the 'Set to' box.
Although rarely useful, the auto increase function (activated with the ' | ' button)
can also be used when setting the Curve. The Curves Table is not stored in the
LanBox until you click the Store Button, and it won't be permanently saved until
you save the LanBox data.
Changing Curves
To change a Curve stored in the LanBox, open the Patch Editor and select the Image 61: The Curve
appropriate Curve from the drop down menu. Curve 0 is the default linear 1:1 Table
Curve and cannot be changed and therefore cannot not be
selected. In the Factory settings, Curve 1 is the 'inverted
linear' Curve where 0 = 255 and 255 = 0, but this can be
changed. All the other Curves are initially 1:1 as well. When
a Curve is selected, a table of 255 values is displayed. The
left value is the 'input' value, the right value the
corresponding 'output' value. You can either change the
Curve by editing the values like you do when changing Patch
or Gain values, or choose to use the Curve Editor.
The Curve Editor is opened by selecting a Curve in the Patch
Editor and clicking the Curve button at the bottom left. The
Curve editor opens initially showing the already stored curve
and a new 1:1 Curve. The new Curve is defined by 2 anchor
points at the coordinates (0,0) and (255,255). There are 2
types of anchor points, smooth points and corner points. The
smooth points are represented by a blue circle, the corner
points are represented by red squares. The black pointer can
manipulate all anchor points but cannot add any points, the
blue pointer can add smooth anchor points as well as move
them, the red pointer can add and move the corner anchor
points. If you select or move a corner point with the blue Image 62: The Curve Editor
pointer it will be changed into a smooth point and vice versa.
To remove anchor points the black '-' pointer can be used. When moving or adding anchor points, the
coordinates of the pointer are displayed in the bottom left of the window.
If you use smooth anchor points, LCedit+ will attempt to create a flowing line through all your anchor
points, but this becomes impossible when a lot of anchor points a close to each other. Note that a curve
can never be made in such a way that the x values 'overlap'.
When you have created a curve, click the Create button to copy the Curve data to the Curve Table. The
Curve Table is not stored in the LanBox until you click the Store Button, and it won't be permanently
saved until you save the LanBox data.
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Slopes
Sometimes it can be required that a DMX value cannot change to quickly. Examples are high power
incandescence (halogen) lights where the power levels get very high when switching to full
instantaneously or big moving lights that swing to much when moving to quickly. To overcome this
problem, the LanBox has the Slope function.
The Slope of a DMX Channel determines the maximum change of a DMX value for each frame. The
default value is 255, which means that any change within a DMX frame is allowed, but if, for instance, the
Slope value is set to 5, the maximum increase of a value is set to 5 every frame. A LanBox frame is
50ms, so with a slope of 5 it would take (255/5) x 50ms = 2.55 seconds for the DMX value to go from 0 to
255 (or the other way around).
The Slope of the DMX Channels can be set by opening the Patch Editor and selecting Slopes from the
drop down menu. Changing a Channel Slope is done by selecting one or more DMX Channels and
setting the Slope value in the 'Set to' box. The Slope Table is not stored in the LanBox until you click the
Store Button, and it won't be permanently saved until you save the LanBox data.

16bit Table
In order to use 16bit DMX controls to their full extend, it is
possible to link 2 (8bit) Mixer Channels to make up one 16bit
value. This information is stored in the LanBox in the 16Bit
table. You can view and edit this table by opening the Global
Settings (Tools → Global Settings... ) and select the 16-bit
Tab (Image 63). Each 16bit pair consists of 2 Channel
numbers which represent the Most and Least Significant
Byte (MSB and LSB). The MSB is responsible for the coarse
parameter adjustment, the LSB in the fine setting.
The 16bit pairs are automatically created when you place a
Fixture with 16bit parameters onto the stage and
automatically removed from the table if you remove the
Fixture. Therefore the only reason to edit the table is when
you want to override the Fixture Library settings.
To edit a 16bit pair, select a pair in the list and type the
correct Channel numbers in the number boxes at the bottom
of the list. The left box is for the MSB, the right for the LSB. If Image 63: The 16bit Table
you want to add a pair, click on the empty line at the bottom
of the list. To remove a pair, select the pair and delete both numbers in the number boxes. Every change
in the list is automatically stored in the LanBox, but won't be permanently saved until you save the
LanBox Data.
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11 Using MIDI
The LanBox-LCX (and in some extend the LCM) has several ways to be controlled with MIDI or to send
MIDI data. This section covers these possibilities.

Setup for MIDI
The LanBox-LCX has two MIDI ports, a MIDI In and a MIDI
Out. These ports do not have a MIDI through function. To
send MIDI signals to the LanBox, connect a MIDI cable from
your MIDI source to the LanBox MIDI In port.
For the LanBox to process the MIDI messages, you will have
to set it up to link MIDI Channels to Layers. This is done in
the Global Settings (Tools → Global Settings...) in the Tab
MIDI (Image 64). Here you can link any of the possible 16
MIDI Channels you would like to use to the Layer you want
to send the MIDI to. This is done by selecting the MIDI
Channel in the list and type the Layer ID into the 'Set to' box.
The Offset is set in the right box, but this is only used when
you are using Note messages (see next section). To avoid
unwanted MIDI commands, it is advised to leave unused
MIDI Channels blank.
When you use SysEx Midi Show Control messages, these
will have to be send to Layers as well. To achieve this, you Image 64: The MIDI Table
can set a Device ID for every Layer in the Advanced Section
of the Layer Control Panel in the box marked MSC. The MSC Device ID can be 0 through 127, although
Device ID 0 is generally reserved for the Master Device. For General SysEx messages, the LanBox itself
also has a Device ID, this is set on on the Comm tab of the Global Settings Window. Make sure that
every Layer and the LanBox itself always have a unique ID.

Note-On and Note-Off
Every Mixer Channel in the LanBox can be directly controlled using MIDI Note messages. When using a
Note-On, the Pitch determines the Channel Number, the Velocity the value. Because MIDI values are
only 7bit and therefore have a maximum of 127, the Pitch value is multiplied by 2. So a Note-On with
Velocity 60 and Pitch 80 will set Channel 60 to 2x80=160 (because 127x2=254, an exception is made in
that case and the Channel value is set to 255). In order to control Channels higher than 127, every MIDI
Channel can be given an offset in the MIDI tab of the Global Settings window (see previous section). So
if, for example, MIDI Channel 1 is given an offset of 127, a Note-On on that MIDI Channel with Pitch 1
and Velocity 127 will set Mixer Channel 128 to 255. a Note-Off command will switch the Channel
determined by the Pitch off, regardless the of Velocity value.
MIDI modes
Because not all MIDI controllers can be set to send Note-On messages on sliders and rotary buttons, the
LanBox can be set to different MIDI modes in order to use different types of messages for the Channel
Control. This Mode is set by giving Channel 3072 (the highest Mixer Channel) a specific value:
MIDI Mode setting (on Channel 3072)
value
mode Description
0-7
0
All MIDI commands as described in the Manual and reference guide
8-15
1
All Poly After Touch messages are handled as Note-On messages
16-23
2
All Control Change (CC) messages are handled as Note-On messages
Poly After Touch messages are handled as CC messages

Note that is is possible to change the MIDI Mode on the fly by using one of the above messages to
control Channel 3072.
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MIDI Control Change Messages
A Lot of control functions of the LanBox can be accessed via MIDI Control Change (CC) Messages. In
order to use MIDI CC Messages, MIDI Channels have to be linked to Layers in the LanBox. This is done
in the Global Settings window (see section Setup for MIDI). A complete list of supported CC messages
with a complete description can be found in the LanBox Reference Document, but the most common
commands are listed below.
CC99 LayerSetTransparencyDepth
With the LayerSetTransparencyDepth command, you can set the Transparency of a Layer. This will
only work if the relevant Layer's Mixing Mode is set to Transparent. The value determines the Layer
Transparency Depth, where 0 = 0% and 127 = 100%
Controller Number

Value

Action

99

0 - 127

Layer Transparency Depth 0% - 100%

CC90 LayerNextStep
The LayerNextStep command will make a Layer Sequencer jump to the next Cue Step. The value is not
used.
Controller Number
90

Value
Not Used

Action
Go next Cue Step

CC91 LayerPreviousStep
The LayerPreviousStep command will make a Layer Sequencer jump to the previous Cue Step. The
value is not used.
Controller Number

Value

Action

91

Not Used

Go previous Cue Step

CC76 LayerSetChaseSpeed
The LayerSetChaseSpeed you can set the speed at which a Layer's sequencer will run. If the Speed
value is 0, the Speed Factor is set to 50%, if it is 127, the Speed Factor is set to infinite, which in practice
means that Cue Steps will be performed with the LanBox frame rate (20 steps/second). The value
determines the Layer Chase Speed , where 0 = 50% and 127 = infinite.
Controller Number
76

Value
0 - 127

Action
Layer Chase Speed 50% - infinite

CC64 LayerSetSustain
The LayerSetSustain command influences the way a Layer behaves when receiving MIDI Notes. Putting
a Layer in Sustain means that all Note-Off and Note-On messages with a velocity 0 will be ignored until
Sustain is turned Off. This way, you can set multiple Channels to a value and reset them all at once. A
value < 64 will switch the Sustain Mode Off, a value => 64 will switch it On.
Controller Number

Value

Action

64

0-63
64-127

Sustain Off
Sustain On

CC65 LayerIgnoreNoteOff
The LayerIgnoreNoteOff command influences the way a Layer behaves when receiving MIDI Notes.
Putting a Layer to Ignore Note-Off mode means that all Note-Off messages will be ignored and only
Note-On messages will be accepted. A value < 64 will switch the Ignore Note-Off Mode Off, a value =>
64 will switch it On.
Controller Number

Value

Action

65

0-63
64-127

Ignore Note-Off Off
Ignore Note-Off On
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MIDI Show Control (MSC)
It is possible to fully control the LanBox with MIDI Show Control (MSC). MSC is a subset of the MIDI
SysEx standard. The purpose of MIDI Show Control is to allow MIDI systems to communicate with and to
control dedicated intelligent control equipment in theatrical, live performance, multimedia, audio-visual
and similar environments. The LanBox implementation of MSC is consistent with the recommended
minimum set 2 (No time code, full data capability). In order to receive MSC commands each Layer should
have its own MSC device ID. When using more than one LanBox in a MSC system, each Layer in each
LanBox should have a unique device ID.
MIDI Show Control messages always have the following format:
F0 7F ID 02 CF CO <data> F7
The device ID points at the Layer, the Command Format CF is always 7F (Lighting). The Data depends
on the command CO and is given in ASCII values. If more then one Data set is required, 00 is used as a
delimiter. The LanBox supports 16 MSC commands, which are completely covered in the LanBox
Reference Document, but a the most common command is the GO command, listed below.
MSC 01 GO
The GO command starts a Cue List at a Cue Step in the targeted Layer. The Cue List number and Cue
Step number are send together, separated by a decimal point , ASCII 42, 0x2E hex. If no Cue List and
Step are given, the Layer will perform a Go on the current Cue List.
General form:
F0 7F ID 02 7F 01 <Cue List> E9 <Cue Step> F7
ID
Layer Device ID
<Cue List>
Cue List in ASCII values
<Cue Step>
Cue Step in ASCII values
Go Cue List <Cue List>, Step <Cue Step> in Layer with Device ID ID
Example:
F0 7F 04 02 7F 01 31 36 36 E9 38 37 F7
04
Layer with Device ID 4 (0x04 hex)
31 36 36
Cue List 166 (ASCII 49 54 54, 0x31 0x36 0x36 hex)
38 37
Cue Step 87 (ASCII 56 55, 0x38 0x37 hex)
Go Cue List 166, Step 87 in Layer with Device ID 4

MIDI Program Change Messages
A Program Change message will start a Cue List which is determined by the Program Change value in
the Layer to which the MIDI Channel is assigned. Because these values can only range from 0 to 127,
the MIDI Bank Select command can be used to set the Bank. This will be the MSB of the Cue List
Number. So a Program Change of 110 on Bank 3 will be Cue List number: (128 x 3) + 110 = 494.
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MIDI Out
In order to let the LanBox send MIDI, a Cue List should be created to do this. The MIDI data has to be
given as 'raw data', which means the hexadecimal representation of the MIDI values. The MIDI message
type and Channel are represented in the first byte of a Message, where the first 4bit nibble (the first
character of a hexadecimal 8bit number) is the Message type, the second 4bit nibble the MIDI channel,
where 0 is Channel 1 and F is Channel 16.
Message Name

Value

Byte 1

Byte 2

Note-Off
Note-On

8c (80 = Note-Off on Channel 1)
9c (9E = Note-On on Channel 15)

Pitch/Key
Pitch/Key

Velocity
Velocity

Poly After Touch
Control Change

Ac
Bc

Pitch/Key
CC number

Pressure
CC value

Program Change
After Touch

Cc
Dc

Program number
Greatest Channel pressure

-n/a-n/a-

Pitch Bend

Ec

Pb LSB

Pb MSB

To program a MIDI Out command, open a (new) Cue List in
the Cue List Editor and double click on a Cue Step to open
the Cue Step Action dialog. In the Special tab, we find the
Write hex function (Image 65). To send a Hexadecimal
command to the MIDI Out port, select MIDI in the drop down
menu. The Port Number only applies to the Serial Ports and
can be ignored. In the text box you can type the hexadecimal
command. Although normally these are typed with upper
case letters, they aren't case sensitive, LCedit+ will change
lower case letters to upper case automatically.
Example
Let's say we have a sound desk connected to the LanBox so
we can fade in or out the sound using a Mixer Channel. In Image 65: The Write hex Cue Step Action
this example, we use Mixer Channel 512 and have set the
sound desk to map Midi Channel 1, Control Change number 16 (0x10 hex) to fader 1. This means that
we will have to write the following commands: B0 (for CC on Channel 1) 10 (for CC number 16) XX,
where XX is a value from 0 to 127. We'll split this up in steps of 8, which leaves us with (128/8 = 16 +1 for
0) 17 steps. The Cue List will look like this:
Step
1>go .3 if channel 512 within 16 - max
2 write B0 10 00 to MIDI 1
3>go .5 if channel 512 outside 17 - 32
4 write B0 10 08 to MIDI 1
5>go .7 if channel 512 outside 33 - 48
6 write B0 10 10 to MIDI 1
7>go .9 if channel 512 outside 49 - 64
8 write B0 10 18 to MIDI 1
9>go .11 if channel 512 outside 65 - 80
10..write B0 10 20 to MIDI 1
11>go .13 if channel 512 outside 81 - 96
12 write B0 10 28 to MIDI 1
13>go .15 if channel 512 outside 97 – 112
14 write B0 10 30 to MIDI 1
15>go .17 if channel 512 outside 113 – 128
16. write B0 10 38 to MIDI 1
17>go .19 if channel 512 outside 129 - 144
18 write B0 10 40 to MIDI 1

19>go .21 if channel 512 outside 145 - 160
20 write B0 10 48 to MIDI 1
21>go .23 if channel 512 outside 161 - 176
22 write B0 10 50 to MIDI 1
23>go .25 if channel 512 outside 177 – 192
24 write B0 10 58 to MIDI 1
25>go .27 if channel 512 outside 193 - 208
26 write B0 10 60 to MIDI 1
27>go .29 if channel 512 outside 209 - 224
28 write B0 10 68 to MIDI 1
29>go .31 if channel 512 outside 225 - 240
30 write B0 10 70 to MIDI 1
31>go .33 if channel 513 outside 241 - 250
32 write B0 10 78 to MIDI 1
33 >go .35 if channel 513 within 0 - 250
34 write B0 10 7F to MIDI 1
35 go .1
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12 DMX Input
With the LanBox it is possible to either merge the DMX signal with the DMX from an external source,
map some external DMX channels or use external DMX channels to trigger events.

Set up DMX Input
The LanBox DMX Input accepts all DMX512-A signals and
has a 5-pin socket. To be able to use the DMX values, the
LanBox has to be told to do so. The DMX Input settings can
be found in the DMX tab of the Global Settings window
(Tools → Global Settings... , Image 66). Here you can set
which DMX Input Channels have to be copied to which Mixer
Channels and which Layer. Note that the number of Input
Channels will have to be equal to the number of Light
Channels and in both cases always has to be one
continuous range. The Light Channels can be any range of
numbers within the LanBox Mixer Channels (1-3072).
In order to actually receive the DMX Input and be able to
work with it, you will have to activate the Channels in the
assigned Layer! If you fail to do this, the DMX values will not
be copied to the Mixer.

Use DMX Input values
Image 66: The DMX In Settings

The DMX Input can be used in several ways, which will be
covered below.
Merging DMX universes
It is possible to merge two DMX universes into one, with several different possible scenario's. We'll cover
these in some examples:
Example: Using Highest Takes Precedence
Situation: The LanBox controls a set of lights, with a light console connected to the DMX In. You want
the highest value of either the Cue Lists running in the LanBox or the light console to overrule the lower
DMX value.
Solution: In the Global settings, copy DMX Input Channels 1-512 to Mixer Channels 1-512 in Layer A
(assuming Layer A is your top Layer). In Layer A, make those Channels you want to apply the DMX Input
to Active (for example, by changing their values). Now, set the Mix Mode of Layer A to HTP (bottom drop
down menu in the Advanced section of the Layer Control Panel). This will make the LanBox ignore all
DMX Input values that are lower than the result of the values in all underlying Layers and only (directly)
copy the higher Channel values to the Mixer.
In the Layers underneath Layer A, you can run Cue Lists as normal.
Example: control a number of Channels externally
Situation: The LanBox controls a set of lights, but a small number of lights (for example, the lights in the
entrance hallway of a venue) need to be controlled by an external lighting console. In our example, these
are 16 dimmer Channels on DMX addresses 497-512.
Solution: In the Global settings, copy DMX Input Channels 1-16 to Mixer Channels 497-512 in Layer A
(assuming Layer A is your top Layer). In Layer A, make Channels 497-512 Active (for example, by
changing their values). Make sure the Mix Mode of Layer A is set to Copy (bottom drop down menu in the
Advanced section of the Layer Control Panel). This will make the LanBox ignore all the values in all
underlying Layers and directly copy DMX Input values of the 16 Channels to the Mixer.
In the Layers underneath Layer A, you can run Cue Lists as normal.
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Mapping external DMX values
In some situations, you might want to control some functions with the LanBox, while controlling others
with an external DMX source. This is possible by copying the DMX Input to otherwise unused Mixer
Channels in the LanBox and use the LanBox DMX Patch to patch these Channels to the desired DMX
Output Channels.
Example: controlling Fixture Intensity with an external console.
Situation: The LanBox controls a the Lighting effects and movements of a group of moving head
Fixtures. The Fixture Intensities though you would like to control with an external console. In this
example, we will use 8 Martin MAC250 Krypton moving heads (in 16bit mode). These Fixtures use 17
DMX Channels each, with the Intensity on Channel 2 of those Channels. We have Patched these
Fixtures on Mixer Channels 1-136 (8x17). We want to use the first 8 DMX Channels of the external
console to control the intensities.
Solution: In the Global settings, copy DMX Input Channels 1-8 to Mixer Channels 513-520 in Layer A
(assuming Layer A is your top Layer). In Layer A, make Channels 513-520 Active (for example, by
changing their values). Make sure the Mix Mode of Layer A is set to Copy (bottom drop down menu in the
Advanced section of the Layer Control Panel). This will make the LanBox ignore all the values in all
underlying Layers and directly copy DMX Input values of the 8 Channels to the Mixer. Now open the
Patch Editor (Tools → Patch Editor) and patch DMX Channel 2 to Mixer Channel 513, 19 to 514, 36 to
515 etc. up to DMX Channel 121 to Mixer Channel 520. Now, all Intensity values for these Fixtures are
overruled by the first 8 Channels of the DMX Input.
Trigger events using DMX Inputs
Making use of the scripting capabilities of the LanBox, it is also possible to use external DMX values to
trigger events in the LanBox or manipulate Layer properties. This way, you can control a vast number of
lights with only a few DMX Channels.
Example: Setting a Layer Transparency Depth with an external DMX value.
Situation: We control the Intensities of some Fixtures with Cue Lists running in Layer B. Furthermore, we
have a small 6 Channel DMX controller with which we want to control these intensities.
Solution: In the Global settings, copy DMX Input Channels 1-6 to Mixer Channels 513-518 in Layer Z (or
just another otherwise unused Layer). In Layer Z, make Channels 513-518 Active (for example, by
changing their values). Make sure the Mix Mode of Layer Z is set to Copy (bottom drop down menu in the
Advanced section of the Layer Control Panel). Now, we are going to create a Cue List setting the
Transparency of Layer B (which has the Intensity Cue Lists running).
Step
1>go .4 if channel 513 within 25 - max
2 set layer B to mix transparent at 100%
3>go .5 if channel 513 outside 26 - 50
4 set layer B to mix transparent at 90%
5>go .7 if channel 513 outside 51 - 75
6 set layer B to mix transparent at 80%
7>go .9 if channel 513 outside 76 - 100
8 set layer B to mix transparent at 70%
9 >go .11 if channel 513 outside 101 - 125
10 set layer B to mix transparent at 60%
11>go .13 if channel 513 outside 126 - 150
12 set layer B to mix transparent at 50%

13>go .15 if channel 513 outside 151 -175
14 set layer B to mix transparent at 40%
15>go .17 if channel 513 outside 176 - 200
16 set layer B to mix transparent at 30%
17>go .19 if channel 513 outside 201 - 225
18 set layer B to mix transparent at 20%
19>go .21 if channel 513 outside 226 - 250
20 set layer B to mix transparent at 10%
21>go .23 if channel 513 within 0 - 250
22 set layer B to mix transparent at 0%
23>go .1

In this example we have only divided the range up in 11 steps, but more steps (and with it greater
accuracy) is off course possible as well. You can make up to 49 steps like this when using 1 Cue List, but
even more if you would use several Cue Lists. This Cue List will have to run in a Layer above Layer Z (or
any other Layer you receive the DMX Input in). This has to do with the processing order of the LanBox
(more information on this you can find in the Advanced section). Now, if you change the value of the first
incoming DMX Channel (Mixer Channel 513 with our setup), the Transparency Depth of Layer B will
change accordingly. This is just one example, but any Cue Step Action can be triggered by incoming
DMX values this way.

DMX Input pag. 52 / 68

LanBox & LCedit+ manual version 4.01
Grabbing DMX Data
You can also use the incoming DMX Data to set scene with an external DMX source and record the
values into a Cue Scene. To do this, create a Cue List using a Record Layer (see the section Editing
using a Layer on page 23), but this time, use the Layer you receive the DMX Input as your Recording
Layer. Set the DMX values on your external source (make sure these appropriate Channels are activated
in the Layer), select the Master Intensity of the Fixtures and hit Enter/Return to copy the Scene Data into
the Cue List Editor. If the Master Intensity is already selected, only hitting the Enter/Return will suffice.
Clicking the Step Forward button or hitting the Space will select the next Cue Step. Change the Hold and
Fade of your Cue Steps to the desired settings before saving your Cue List!

DMX Input pag. 53 / 68

LanBox & LCedit+ manual version 4.01

13 In/Out Port
The LanBox-LCX has a DC37s D-sub containing 8 I/O ports which can be used to send and receive
analog signals as well as sending serial commands to other devices. These ports can be completely
controlled and used by Cue Step Actions. The Pin Out of the D-sub plug is shown in Image 67 and the
table below. Note that all 6V outputs are identical and all 0V are all connected to the ground.
Pin

Pin

1

0V

20

0V

2

0V

21

In 8

3

In 7

22

Out 8

4

Out 7 23

5

+6V

24

0V

6

0V

25

In 6

7

In 5

26

Out 6

8

Out 5 27

9

+6V

28

0V

10

0V

29

In 4

11

In 3

30

Out 4

12

Out 3 31

13

+6V

32

0V

14

0V

33

In 2

15

In 1

34

Out 2

16

Out 1 35

17

+6V

36

0V

18

0V

37

0V

19

0V

+6V

+6V
Image 67: The LanBox-LCX D-sub Pin Out

+6V

+6V

Setting up the Analog Inputs
In order to use the Analog Inputs, some sort of sensor will have to be connected. The simplest version of
this is a push button or switch, put potentiometers and more advanced sensors as light sensors are also
possible. The Analog ports can detect the electric potential difference between the Input Pin and the
ground. This potential can have a maximum value of 5V. The readout of the Analog Inputs 1-8 is copied
to Mixer Channels 3061-3068, but can also be monitored directly in the LCedit+ DMX monitor (see the
section The DMX Monitor on page 30). Note that the analog values are 10bit instead of 8bit (a range of 01024), so 16 values are shown for the External Inputs in the DMX
monitor, 8 pairs of a Most Significant and a Least Significant Byte
(MSB and LSB). The first of the 2 values (the MSB) has to be
multiplied by 256 and added up to the second value (the LSB) to
get the Input value. So a value of 2 56 means (2x256)+56=568,
which is equivalent to (568/1024)x5V = 2,77V.
Connecting a switch
In order to avoid interference, the +6V voltage should be connected
to the Input (look at the Pin Out to see which pins to use), using a
4700Ω resistor to stabilize the voltage and avoid a short circuit. Now
you can connect a switch or button between the Input and the
ground (0V). This results in a 5V potential (because of the resistor it
is 5V instead of 6V) when the switch is open, but closing the switch
will connect the Input to the Ground making the potential difference
0V. This will result in a Input value of ~1024 when the switch is
Image 68: Connecting a switch to the
open and a value of ~0 when closed.
LanBox
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Connecting a potentiometer
To connect a fader, rotary knob or any other potentiometer,
connect the potentiometer Input to the +6V, the potentiometer
Output to the LanBox Input and the potentiometer Common to the
LanBox 0V (Image 69). For the best results, we advice using a
linear 5kΩ – 10kΩ potentiometer. As the resistance of the
potentiometer varies, the potential on the Input of the LanBox
changes from 6V at the minimum resistance to 0V for the
maximum. In this setup, the 5V mark (= the maximum for the
Input) is reached a bit before the potentiometer is at it's minimum
which will result in a Input value of 1024 before the potentiometer
has reached it's minimum. Connecting a resistor between the +6V
and the potentiometer resolves this. The value of this 'voltage
divider' is calculated as follows:

Rdivide = R fader −

(R fader ∗V output )
V input

Image 69: Connecting a potentiometer

Rdivide is the voltage divider resistor value, Rfader the potentiometer to the LanBox
maximum resistance, Voutput the desired output voltage (= 5V) and
Vin the input voltage (=6V). Filling in the voltages gives us the the more comprehensible formula:

1
Rdivide = ∗R fader
6

This means that for a 10kΩ potentiometer a 10*1/6=1,7 kΩ
resistor is needed, but generally a 2kΩ will do the trick. If you
don't need this precision, the voltage divider can be left out.

Using Analog Inputs as trigger
Using the Analog Inputs to trigger events is done in roughly
the same way as you would do with the DMX Input. The
trigger Cue Steps can be made by selecting the Go to Step if
Input function in the Go tab of the Step Action window
(Image 70). The Input number can be 1 – 8, the value is
either within or outside a range of 0 – 1023(max).
Example: Starting different Cue Lists depending on the
Analog Input value.

Image 70: Using the Analog Input in a Cue
Step

Situation: We want to start 5 different Cue Lists (201
through 205), and select the Cue List using a rotary potentiometer connected to Analog Input 1. When
the potentiometer is switched off, we want to stop everything, when it is on, we want to start Cue List 201,
202, 203, 204 or 205, depending on the value.
Solution: In Layer B we run a Cue List (200) which checks the value of Analog Input Channel 1 and
starts Cue Lists in Layer A. If the value is 1023, we want Layer A to be cleared. In order to do that we
start Cue List 0 there. Note that if we just kept checking the value, Cue Lists will be started over and over.
That's why we have to put a precaution in the Cue List: go back to the 'check state' sequence only if the
Input value is outside the specified range.
Step
1>-- check i1
2 go .9 if input 1 within 1023 - max
3 go .12 if input 1 within 818 - 1022
4 go .15 if input 1 within 613 - 817
5 go .18 if input 1 within 408 - 612
6 go .21 if input 1 within 203 - 407
7 go .24 if input 1 within 0 - 202
8 -- start CL
9>go 0.0 in layer A
10>go .1 if input 1 within 0 - 1022
11 go .10
12>go 201.1 in layer A
13>go .1 if input 1 outside 818 - 1022

14 go .13
15>go 201.1 in layer A
16>go .1 if input 1 outside 613 - 817
17 go .16
18>go 201.1 in layer A
19>go .1 if input 1 outside 408 - 612
20 go .19
21>go 201.1 in layer A
22>go .1 if input 1 outside 203 - 407
23 go .22
24>go 201.1 in layer A
25>go .1 if input 1 within 203 - max
26 go .25
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Example: Starting different Cue Lists with push buttons
Situation: We want to start 7 different Cue Lists (201 through 207) or switch them all off using 8 push
buttons connected to Analog Inputs 1 - 8. Button 1 should start Cue List 201, 2 Cue List 202, etc. up to
button 8 which should switch all the Cue Lists off.
Solution: In Layer B we run a Cue List (200) which checks the value of Analog Input Channels 1 – 8 and
starts Cue Lists in Layer A. For every Analog Input, a high value (~1023) means the button is idle, a low
value (~0) means it's pressed. To avoid a Cue List being started several times when a button is pressed
(or 2 Cue Lists are attempted to be started simultaneously), we build in a sequence that checks if the
button is let loose again.
Step
1>go .10 if input 1 within 0 - 100
2 go .13 if input 2 within 0 - 100
3 go .16 if input 3 within 0 - 100
4 go .19 if input 4 within 0 - 100
5 go .22 if input 5 within 0 - 100
6 go .25 if input 6 within 0 - 100
7 go .28 if input 7 within 0 - 100
8 go .31 if input 8 within 0 - 100
9 go .1
10>go 201.1 in Layer A
11>go .1 if input 1 within 500 - max
12 go .11
13>go 202.1 in Layer A
14>go .1 if input 2 within 500 - max
15 go .14
16>go 203.1 in Layer A
17>go .1 if input 3 within 500 - max

18 go .17
19>go 204.1 in layer A
20
21 go .20
22>go 205.1 in layer A
23>go .1 if input 5 within 500 - max
24 go .24
25>go 206.1 in layer A
26>go .1 if input 6 within 500 - max
27 go .26
28>go 207.1 in layer A
29>go .1 if input 7 within 500 - max
30 go .29
31> go 0.0 in Layer A
32>go .1 if input 7 within 500 - max
33 go .32

Set up Digital Outputs
The LanBox-LCX has 8 TTL compatible Digital Outputs
which can be used to trigger relays. The maximum load on
each Digital Output is 20mA and the Output voltage can
switch between 0V and 5V. Relays and LEDs can be
connected to these ports directly (obviously taking voltage an
amperage into account). In order to control the Digital
Outputs, they should be linked to a Channel. This is done in
the DigOut tab of the Global Settings (Tools → Global
Settings..., Image 71). Here you can assign a Mixer Channel
to each Digital Output by selecting the Output and entering a
Mixer Channel in the number box below. It is possible to
assign multiple Outputs to one Mixer Channel.
The value of the assigned Mixer Channel will determine the
Digital Output state. If the Channel has a value of 128 or
higher, the Output is switched On and have a voltage of 5V.
At a value of 127 or less, the Output will switch Off.
The Mixer Channel assigned to a Digital Output can be Image 71: Digital Outputs Setup
programmed and used in the same way as any other Mixer
Channel. Advised is to represent the Channel(s) by an
On/Off Switch on the Stage.

Using the Digital Output as a Serial Port
The LanBox-LCX can switch the Digital Outputs at such a
speed that they can also be used as 9600 baud Serial Ports.
In order to use them, the Digital Output should be linked to a
Channel (see previous section) and the Channel should be
set to either 0 or 255 depending on the serial protocol. The
serial output can be used to send most RS232 commands.
The Digital Output of the LanBox should be connected to the
Data Deceive (Rx+) pin of the RS232 connector, and the 0V
to the signal ground/common.

Image 72: Serial command Cue Step Action
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In order to send serial commands, they will have to be programmed in Cue Steps, similar to the MIDI Out
discussed on page 50. To program a Serial command, open a (new) Cue List in the Cue List Editor and
double click on a Cue Step to open the Cue Step Action dialog. In the Special tab, we find the Write hex
function (Image 72). To send a Hexadecimal command to a Digital Out port, select Ser in the drop down
menu and select the appropriate Port Number. In the text box you can type the hexadecimal command.
Although normally these are typed with upper case letters, they aren't case sensitive, LCedit+ will change
lower case letters to upper case automatically. You can send a 5 byte message per LanBox frame (5ms).
If you command is longer than 5 bytes, it will have to be split up in 5 byte chunks, separated by a 'hold for
0.05s' Cue Step to force the LanBox to wait until the next frame. If this isn't done, the new bytes will be
sent and the previous sequence overwritten.
Example
We have connected an iPod to Digital Output 3 of the LanBox. We want the LanBox to trigger the iPod to
start playing if a push button connected to Analog Input 1 is pushed, and stop when a push button
connected to Analog Input 2 is pushed. Digital Output is linked to Mixer Channel 3003 and we have
looked up the Serial Commands for Play and Stop for the iPod. These are:
Play: FF 55 04 02 00 00 01 F9
Stop: FF 55 03 02 00 80 7B
And this one to make the iPod perform the action (it won't work without this command!):
Button Release: FF 55 03 03 00 00 FB
See Appendix II: iPod Serial Commands for the complete command Chart.
The Cue List will look like this:
Step
1-- BUTTON1
2>go .9 if input 1 within 0 - 100
3 go .2
4-- BUTTON2
5>go .20 if input 2 within 0 - 100
6 go .5
7
8 – PLAY
9>write FF 55 04 02 00 to SER 1
10 hold for 0.05s
11 write 00 01 F9 to SER 1
17 go .5

18-19--STOP
20>write FF 55 03 02 00
21 hold for 0.05s
22 write 80 7B to SER 1
23 hold for 0.05s
24--RELEASE
25 write FF 55 03 03 00 to SER 1
26 hold for 0.05s
27 write 00 FB to SER 1
28 go .2

Using the MIDI Port as a Serial Port
When the baud rate of the MIDI port is set to 9600, it can
also be used as a Serial port. This can be done in the comm
tab of the Global Settings window (Tools → Global
Settings...). Uncheck the 'Use serial/MIDI port for MIDI' box
and select 9600 baud as the Serial port rate (Image 73).
Note that the LanBox will have to reboot if you change the
baud rate of the MIDI port.
Pin 4 of the MIDI port corresponds with the Data Transmit of
a serial port, pin 5 with the ground/common.

Image 73: Setting the MIDI port as a serial
port
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14 UDP Networking
The LanBox-LCX and LCE have several options for using UDP (User Datagram Protocol) to transfer data
on an Ethernet network. UDP is a fast protocol that is very suitable for sending and receiving bulk data
(such as DMX). UDP can be used to synchronize several LanBoxes and to capture or send DMX Data
with third party software.

Sending Channel data
To send your Channel data with UDP, this will have to be set
up in the UDP tab of the Global Settings window (Tools →
Global Settings...). Check the box 'Broadcast mixer
channels:' and fill in the range of Channels you want to
broadcast (Image 74). The UDP port is 4777 by default, but
this can be changed into any required port number. Note that
some UDP ports are reserved for use by other software and
network protocols, so make sure you use a free port (this
information is readily available on the internet).
It is also possible to broadcast the DMX Output and Input,
the Analog Input values (ext input) and your Layer
Information. These options can be used for other purposes
explained in further sections.
In this example we have chosen to broadcast Mixer Image 74: Setting up Channel Broadcast
Channels 513 – 1024 ('DMX universe 2'), so it can be picked
up by another LanBox.
Make sure that every LanBox in your network has an unique IP address!

Receiving Channel data
To set up the receiving of Channel Date using UDP, open
the UDP tab of the Global Settings window (Tools → Global
Settings...). To receive Channel data a range of Channels
has to be set which will be copied to the set Mixer Channels.
The amount of Channels set in the 'copy light channels:' and
in the 'to light channels:' boxes naturally have to be equal,
which LCedit+ will make sure of when filling in the Channel
numbers. You have the option to copy the Channel values
either directly to the Mixer or to a Layer. When you copy the
Channel values to a Layer these Channels will have to be
activated in that Layer. Channels which aren't activated won't
have the UDP values copied. This way you can choose
which Channels you want to control in the LanBox, and
which you want to copy directly (see also the section Use
DMX Input values on page 51).

Synchronizing multiple LanBoxes

Image 75: Setting up Channel Receive

Multiple LanBoxes can be set up to run synchronized, so if, for example, you start Cue List 1 in Layer A
of the Master LanBox, the Slave LanBox shall do the same. To achieve this, in the UDP tab of the master
LanBox Global Settings window, check the box 'Broadcat layer list'. This will make that LanBox broadcast
all its Layer information over UDP. On the Slave LanBox, check the box 'Synchronize layers with the
same ID' in the UDP tab of the Global Settings window. Now, this LanBox will perform all the Layer
actions of the master LanBox, but only for Layers that share the same ID. This way it is possible to
synchronize multiple DMX universes.
Note that this is especially useful if the amount of Cue Scene Data (the Channel values in the Cue Lists)
threatens to be too large to be stored on a single LanBox. If this isn't the case, it is advisable to run all
Cue Lists in one LanBox to ensure better timing and broadcast the Channel data only.
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Synchronizing with software
The UDP functions of the LanBox can be used to monitor the Channel data of the LanBox or to control its
Channel values in a very direct way using third party software. In order to work with the LanBox UDP
streams, an understanding of the stream format is required.
The general form of a LanBox UDP stream is as follows:
Header:

C0 B7 SEQU
where: SEQU is the 16bit sequence number (sent by the LanBox but ignored when receiving)
One or more messages:
MT BU LENG INDX <data>
where: MT
Message Type. CA for Buffer Write: ignores LanBox Settings and copies
values directly to Buffer and Offset stated in the Message.
C9 for Buffer Broadcast: the LanBox copies Mixer buffer
Data to Layer specified in UDP receive Settings
D1 for Layer Information Broadcast.
BU
Buffer ID (8bit) 01 – 3F (1 – 63) for Layer A – BK
FC (252) for DMX Input
FD (253) for Analog Input
FE (254) for Mixer
FF (255) for DMX Output
LENG 16bit message length in 8bit bytes
(complete message, including MT, BU LENG and INDX, excluding padding)
INDX
16bit start index of the broadcast channels (only Message Type CA and C9)
<data> consists of n x 8bit values
Note that the LanBox can transmit all Buffer ID types, but will only accept 01 – 3F and FE (Layers and
Mixer) as Buffer ID when receiving. If a message has an odd length, a padding byte is added to make
sure that the next message will have a 16bit alignment.
Supported software
The following software is known and tested to work with the LanBox.
Cycling 74 MAX
The standard MAX UDP objects are made to handle OSC messages, but by adding the argument lanbox
they will receive the LanBox UDP stream as FullPacket messages. Use the LanBox specific Max
externals (together with examples available for download on our website and included in the LCedit+
package) to decode and encode these messages.
Troikatronix Isadora
Isadora can convert its data to LanBox compatible UDP DMX data packets. Examples are available for
download on our website and included in the LCedit+ package.
Capture by Capture Sweden
The Capture software by Capture Sweden supports the LanBox as input device. It supports up to 6
universes of DMX data. Set the LanBox to broadcast Mixer Channels 1-3072 to use all these universes.
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Art-Net support
Art-Net is a special protocol designed and copyrighted by Artistic License LTD which is based on UDP.
Its purpose is to allow transfer of large amounts of DMX data over a wide area using standard networking
technology. The LanBox can be set to send and receive DMX data in the Art-Net format in the UDP tab of
the Global Settings window.
Note: by default, the Art-Net protocol uses IP addresses in the 2.x.x.x range. These can be valid Internet
IP addresses as well. Only use these addresses when there is no connection to the internet! Use 10.x.x.x
or 192.168.x.x addresses instead as these are reserved to be used in local networks.
Broadcasting Art-Net
To set up Art-Net broadcast on the LanBox, open the UDP
tab of the Global Settings window (Tools → Global
Settings...). Check the box 'Use Art-Net'. The sub net
number can be entered in the 'sub net' box in the top right
and can have a value of 0 – F (0 – 16). Now you can assign
a Universe number (0 – F as well) to 4 ranges of Mixer
Channels (Image 76). Because Art-Net supports a maximum
of 4 Universes from one source IP address, only the Mixer
Channel 1 – 2048 can be linked to an Art-Net Universe. Note
that the Universe numbers have to be increasingly and
sequentially numbered (so Universe 0 for 1 – 512 and 1 for
513 – 1024 is OK, but not the other way around or 0 for 1 –
512 and 2 for 513 – 1024)! The numbers in the 'Broadcast
mixer channels' box will change but this should be ignored.
Note that the UDP port will automatically change in 6454,
the Art-Net port.
Receiving Art-Net

Image 76: Setup for broadcasting Art-Net

The LanBox has the capability to copy the values of 1 ArtNet universe to a Layer or directly to the Mixer. In order to do
this, open the UDP tab of the Global Settings window (Tools
→ Global Settings...). Check the option 'Art-Net universe: '
and fill in the sub net (0 – F, first number box) and universe
(0 – F, second number box) from which you want to copy the
DMX values (Image 77). The 'copy light channels' box will
automatically select the DMX channels associated with the
selected Universe and sub net. In the 'to light channels' box,
fill in the range of Mixer Channels you want to copy the DMX
values to. Note that this will always have to have a length of
512 channels.
You can choose to either copy the DMX values directly to the
Mixer or to a specified Layer. When you copy the Channel
values to a Layer these Channels will have to be activated in
that Layer. Channels which aren't activated won't have the
Art-Net values copied. This way you can choose which
Channels you want to control in the LanBox, and which you Image 77: Setup for receiving Art-Net
want to copy directly (see also the section Use DMX Input
values on page 51).
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15 Advanced
Backup and Restore
Using LCedit+ it is possible to backup the contents of the LanBox memory to upload it again later. Note
that everything is stored except for the Layer information! A workaround for this is described further on in
this section.
Making a backup
In order to make a backup, select Tools → Backup... in the menu. A
Window will appear where you can give the backup a name and
select which tables and Cue Lists you want to save (Image 78). Go
through you Cue Lists thoroughly and deselect the Cue Lists you
won't need to save. This will save you valuable LanBox memory
capacity when you restore the backup later. This way, you can also
choose only to backup a number of Cue Lists which you would like to
copy to another LanBox.
Backup files are saved in the 'Backup Files' folder in the LCedit+
folder.
Restoring a backup
In order to restore a previously stored LanBox backup, select Tools Image 78: LanBox backup window
→ Restore... in the menu. A window will appear where you can
select the backup you want to restore (Image 79). Choose the
backup you want to restore and expand the backup item. LCedit+ will
note restore the backup when the item is still collapsed! When the
backup item is expanded, you can select which tables and Cue Lists
you would like to upload to the LanBox.
Do not forget to save the LanBox Data after performing a backup
restore!
Layer and Channel Information
The Layer and Channel information are not saved when you backup
the LanBox. All these settings can also be applied through the use of
Cue Step actions though. The easiest workaround therefore is to
make one Cue List in which all Layer and Channel Settings are
applied an backup this Cue List with the rest of the backup.

Uploading firmware

Image 79: The backup restore
window

Now and then there is a firmware update for the LanBox. These may
contain new features or bug fixes. To upload new firmware, make sure you
have the right version downloaded and unpacked. Note that the (P) version
of the LCX firmware is a special version that blocks the possibility to
change some vital settings using an Ethernet connection. This version is Image 80: The Interface
meant for situations where the LanBox is easily accessible through an Status Window
Ethernet connection by many people (for instance an educational setup or
our demo.lanbox.com). The current firmware version is displayed in the Interface status window in the
Advanced Layer Options panel when connecting to the LanBox (Image 80).
To upload new firmware, select Tools → Upload firmware...
in the menu. The Firmware upload window will appear.
Select Upload and select the firmware file on your system.
LCedit+ will attempt to connect to your LanBox and enter the
Bootstrap mode to start uploading the new firmware. Do not
interupt this process! If the process is interrupted, a factory
reset will have to be performed. When the firmware upload is
completed, the Firmware upload window will show the text:
“Firmware upload complete” (Image 81). Click OK to exit the
Image 81: The Firmware upload window
Firmware upload window.
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LanBox Utilities
In the LanBox Utilities window you can query the memory
status and a list of everything stored in the connected
LanBoxes. To open the LanBox Utilities window, select Tools
→ LanBox Utilities in the menu. Clicking List will display the
information of the active Interface (if you have more than one
LanBox connected, select a Fixture on the other LanBox to
switch between each LanBox). The window will display the
amount of used and free memory in the selected LanBox,
and a list of all the Cue Lists stored in it (Image 82). The
Usage button has no function when using the LanBox LCX,
LCE or LCM.

Erase LanBox

Image 82: The LanBox Utilities window

With Tools → Erase LanBox..., you can erase all contents of
the LanBox, and set all settings except for the name, network
settings, password and baud rate to the factory defaults. This
will delete all show data and this process may not be
interrupted!

Reboot LanBox
With Tools → Reboot LanBox..., you can perform a soft reboot
of the LanBox. All unsaved data will be lost!

Factory Reset
If the LanBox has been powered off while saving or during a
firmware upload, its firmware may be corrupted and the LanBox
will not boot properly any more. As a last resort you can
perform a factory Reset, which will delete all data from the
LanBox and set all settings to the default settings. Also if you
have forgotten the password this is a way to reset it to 777
again (although not without losing all your data). To perform the
factory reset it is required to open the LanBox. Remove the top
cover by undoing the top two screws on both the front and the
rear panel of the LanBox. Lift up the cover and locate the reset
button (Image 83). To reset the LanBox, keep this button
pressed for 15 seconds while powering up the LanBox (the
button need to be pressed before powering up and has to be
pressed continuously). Reboot the LanBox again and the
LanBox should be reset to the factory defaults. This also means
that the firmware is reset to the version originally installed.
Image 83: The factory Reset button
Upload new firmware when this wasn't the latest version.

Connecting Multiple Interfaces
It is possible to connect to more than one LanBox at once inside one LCedit+ project. To connect to a
second LanBox, the Interfaces window has to be opened and active (Window → Interfaces). With the
Interfaces window active, select Edit → New Interface... to open a new Configure Interface window. Make
sure to give every LanBox connection you make a unique name to avoid confusion.
To switch between each connected LanBox, place at least one Fixture on your stage for every interface
(select the appropriate LanBox in the Interface drop down menu when creating a Fixture). The Control
Panel and DMX Monitor will automatically switch to the LanBox associated with the selected Fixture on
the Stage. The Cue List Editor can switch using the Interface drop down menu in the bottom right.

Auto Update
In normal operation, LCedit+ automatically updates all its information as quickly as possible. In some
circumstances though, this might not be desirable. To toggle the Auto Update, select Tools → Auto
Update in the menu (Ctrl Alt + R / ⌘ ⌥ + R). When deactivated, the LCedit+ will only update its
information on demand. To Update, select Tools → Update Now or press Ctrl + R / ⌘ + R. The Auto
Update state is saved with your project, so if it is switched off when you save your project, it will be
disabled when you load it again as well!
Advanced
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Debug Mode
If you switch LCedit+ into Debug Mode (Tools → Debug Mode) you add some extra diagnostic functions
in LCedit+. These functions can be used for debugging, troubleshooting and development purposes.
StreamWatcher
The StreamWatcher window displays all the communication between the LanBox and LCedit+. Make
sure to switch Auto Update off before you open the StreamWatcher! If Auto Update is switched on, there
will be continuous communication and you will not be able to see any useful data! To open the
StreamWatcher, make sure LCedit+ is in Debug Mode and select Window - > StreamWatcher. Now you
can see all the commands from LCedit+ (if you give one) and the answer from the LanBox. For the exact
meaning of the commands, see the LanBox Reference documentation.
Send Raw Command
With the Send Raw Command window, you can manually send commands to the LanBox and see the
LanBox replies. To open the Send Raw Command window, make sure LCedit+ is in Debug Mode and
select Window - > Send Raw Command. For the exact meaning of the commands, see the LanBox
Reference documentation.
Log to File
You can also monitor the communication between the LanBox and LCedit+ by logging it to a file. To do
this, make sure LCedit+ is in Debug Mode and select Tools - >Log to File. Now, all the communcation is
logged to a text file. This file is saved when you disable the logging again (again with Tools - >Log to
File). The log file is saved in the LCedit+ folder and is named Debug Stream Log. For the exact meaning
of the commands, see the LanBox Reference documentation.

LanBox firmware operation
In order to make complicated shows, it is useful to understand the order in which the LanBox performs its
calculations. The order of calculations has
been visualized in Image 84. The black
vertical arrow represents the calculations
made every LanBox frame, in that order.
Note that the bottom Layer in the LanBox is
processed first, the top Layer last.
The blue arrows represent the 'real time'
streams. This data is copied to the
appropriate buffer or Layer as soon as it
arrives.
What is especially important to keep in
mind is that first the Cue Step Action is
performed in a Layer before the Channel
Data is copied to the Mixer. This means
that 'if channel' Cue Step Actions shouldn't
be performed in the same Layer the
Channel data is copied to, but at least one
Layer up.

Image 84: LanBox firmware operation
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Appendix I: ColorSpot 250AT DMX chart

source: http://http://www.robe.cz/fileadmin/robe/downloads/dmx_charts/ColorSpot%20250%20AT%20DMX%20charts.pdf
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source: http://http://www.robe.cz/fileadmin/robe/downloads/dmx_charts/ColorSpot%20250%20AT%20DMX%20charts.pdf
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source: http://http://www.robe.cz/fileadmin/robe/downloads/dmx_charts/ColorSpot%20250%20AT%20DMX%20charts.pdf
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source: http://http://www.robe.cz/fileadmin/robe/downloads/dmx_charts/ColorSpot%20250%20AT%20DMX%20charts.pdf
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Appendix II: iPod Serial Commands
Each command is build up as follows:
Header
A Length
B Mode
C Command
D Parameter
Checksum

FF 55
1 byte
02 (basic commands)
2 bytes, see list
Optional, depending on command
0x100 - (Sum of length, mode, command and parameter) &0xFF

This results in the following commands:
Command

Header

length

mode

command

Button release

FF 55

03

02

00 00

parameters

checksum
FB

Play/Pause

FF 55

03

02

00 01

FA

Vol +

FF 55

03

02

00 02

F9

Vol -

FF 55

03

02

00 04

F7

Skip forward

FF 55

03

02

00 08

F3

Skip back

FF 55

03

02

00 10

EB

Next album

FF 55

03

02

00 20

DB

Prev. album

FF 55

03

02

00 40

BB

Stop

FF 55

03

02

00 80

Play

FF 55

04

02

00 00

01

F9

Pause

FF 55

04

02

00 00

02

F8

Mute (toggle)

FF 55

04

02

00 00

04

F6

Next play list

FF 55

04

02

00 00

20

DA

Prev. play list

FF 55

04

02

00 00

40

BA

Shuffle (toggle)

FF 55

04

02

00 00

80

7A

Repeat (toggle)

FF 55

05

02

00 00

00 01

F8

Off

FF 55

05

02

00 00

00 04

F5

On

FF 55

05

02

00 00

00 08

F1

Menu button

FF 55

05

02

00 00

00 40

B9

OK

FF 55

05

02

00 00

00 80

79

Scroll up

FF 55

06

02

00 00

00 00 01

F7

Scroll down

FF 55

06

02

00 00

00 00 02

F6

7B
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